The app crashes on Debian due to HW acceleration

Reply

The app crashes on Debian due to HW acceleration

manu_romero_411
Casual Listener

Plan

Free

Country: Spain

 

Device

HP Stream 11-y00ns

Operating System

Debian 10 Buster amd64 (Linux 4.19.0-11)

 

My Question or Issue

I installed Debian 10 yesterday on my 11' laptop via a net-install, and when I've tried to install the app (apt version, not snap) and setup my Spotify account, I've found that I can only open Spotify once in an user session. The error that appears in the terminal is the following:

 

[1007/232300.932739:FATAL:gpu_data_manager_impl_private.cc(439)] GPU process isn't usable. Goodbye.

 

I've found on the internet that it also happens in Google Chrome, and can be worked around by disabling the hardware acceleration... How could that be done on Spotify, since there is no option that enables me to do that on the GUI? Maybe a command-line parameter?

 

Thanks in advance

20 Replies

erickariuki
Newbie
Try running
spotify --no-zygote
It worked for me

qsxefv123
Visitor
try spotify --no-zygote

hal4ed
Casual Listener

Thanks a lot.

spotify --no-zygote

works for me well.

 

 

Ottanta
Casual Listener
With MX Linux MX-19.3 64-bit, based on Debian 10 Buster:

- in file /$HOME/.config/spotify/prefs I've changed to "false" the value of app.autostart-configured=true
- I've started the program with parameter --disable-gpu

This has unlocked Spotify, and now the program runs without problems in graphical mode

HarvHou
Visitor

I'm having a similar problem on Ubuntu 18.04 using the MATE desktop environment:

 

$ spotify --disable-gpu --disable-software-rasterizer
[1020/210753.085523:FATAL:gpu_data_manager_impl_private.cc(439)] GPU process isn't usable. Goodbye.
Trace/breakpoint trap (core dumped)

 

As you can see, I tried the --disable-gpu command, and the Chromium command --disable-software-rasterizer, but with very little success. Also, the times it does work, it tells me that I'm offline!

SciBoy
Newbie

I'm on Archlinux and I have the same problem. Sometimes I can start Spotify, though, and recently I noticed in the .config/spotify/prefs-file that the user name was in all lower-case. I changed it and then spotify started. But I fear that this is only a coincidence.

 

blazemore
Music Fan

Same issue, no solution. Sometimes rebooting helps. There is no pattern.

Once it decides it's going to stop working for a session, that's it.

Sometimes it will open but it's just a black screen.

 

Most of the time it's this:

 

$ cat /etc/issue.net
Ubuntu 20.04.1 LTS
$ spotify --disable-gpu --disable-software-rasterizer
[1206/122933.629502:FATAL:gpu_data_manager_impl_private.cc(439)] GPU process isn't usable. Goodbye.
[1] 13440 trace trap (core dumped) spotify --disable-gpu --disable-software-rasterizer

blazemore
Music Fan

Here is a screenshot showing the black screen.

y6flulf[1].png

groving
Visitor

I'm open file /$HOME/.config/spotify/prefs and DELETE string language='en' and worked!

SSoares
Casual Listener
The string language='en' doesn't exist in prefs file.

rfrail3
Newbie

It's hard to belive, but this works sometimes:

 

while true; do spotify && exit; done



Aggserp4
Newbie
Having the same problem on Ubuntu 20.04.1.

Jalaj
Casual Listener
I am also facing the exact issue but only with spotify. Other apps based on Chromium such as Chrome and VS Code work perfectly fine for me. And yes, the command line didn't help

Sebasty
Rock Star 18
Rock Star 18

Looking around, I found a guy showing how to solve Chrome's gpu-related error messages.

Considering Spotify seems to be Chromium-based, I would try this:

spotify --disable-gpu --disable-software-rasterizer

 

I'm not sure if it'll work (I don't get this error myself, so can't test), but won't hurt to try.

 

SebastyRock Star 18
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

RJ63
Visitor

FYI over here https://community.spotify.com/t5/Desktop-Linux/Getting-error-GPU-process-isn-t-usable/td-p/5051142 it suggests using the --no-zygote flag, which works for me.

wokkiedokkie
Music Fan

same thing on ubuntu 16.04LTS. I also ran into hw acc issues with chrome, chromium and Brave, which I solved with disableing hardware accelleration.

 

unfortunately the command line parameter doesn't work for me either.

Wolfdale
Casual Listener

Try run it with "--disable-gpu", it works for me!

 

Captura de pantalla_2020-10-08_00-30-09.png

SSoares
Casual Listener

I have the same problem using Ubuntu 18.04.
'spotify --disable-gpu' open the Spotify, but it closes on its own soon after.

manu_romero_411
Casual Listener
Does not work for me 😞
Thank you anyway

Wolfdale
Casual Listener
Same problem!
SUGGESTED POSTS