Help Wizard

Step 1

NEXT STEP

not working on newest Debian

not working on newest Debian

Plan

Premium

Country

NL

Device

PC (i386)

Operating System

Debian GNU/Linux 11 (bullseye)

 

My Question or Issue

cannot install on Debian 

 

 

micha@tuin:~$ sudo apt install spotify-client
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
spotify-client : Depends: libcurl3 but it is not installable
Recommends: libavcodec-ffmpeg56 but it is not installable or
libavcodec-ffmpeg-extra56 but it is not installable or
libavcodec54 but it is not installable or
libavcodec-extra-54 but it is not installable
Recommends: libavformat-ffmpeg56 but it is not installable or
libavformat54 but it is not installable
Recommends: zenity but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
micha@tuin:~$

 

 

 

 

Reply
3 Replies

You need to manually provide libcurl3 and libssl1.0.2 files to meet the i386 client's dependencies. I am not allowed to provide modified package to save your time here; please search the web for more instructions.

This way I don't come to solution. I have installed libcurl3-gnutls This contains libcurl-gnutls.so.3

But no way

unerfüllte Abhängigkeiten:

spotify-client: hängt ab von: libcurl3 ist aber nicht installierbar / not installable

spotify-client ist definitiv seit Jahren nicht installierbar! Wann ändert sich das???

 

 

 

 

 

 

 

 

 

 

No, libcurl3-gnutls cannot replace libcurl3. So you still need the libcurl3 and libssl1.0.2 files...

Suggested posts