Help Wizard

Step 1


"Spotify can't play this right now" on local files

"Spotify can't play this right now" on local files

Plan: Premium, although that doesn't matter for local files

Operating System: Debian bookworm/sid


$ spotify --version
Spotify version, Copyright (c) 2022, Spotify Ltd


Spotify can't play local files anymore (new laptop). They are being detected and show with the right metadata. Selecting them to play gives the dreaded "Spotify can't play this right now" message. All streaming (non-local) songs works fine.


Things already done reading various other reports on this:

  • Full wipe of local settings/cache (rm -rf ~/.config/spotify ~/.cache/spotify)
  • Mess with the "streaming/download quality" settings (nothing works, regardless)
  • Install ffmpeg with all dependencies

Pretty stumped about what now. Any hints?



12 Replies

Got this same issue as well, on Gentoo Linux on the new spotify client; didn't use to have this issue and I have also tried everything you tried as well

Spotify only supports libavcodec/libavformat 54,56,57 and 58. Looks like a two new major versions of libavcodec have been released, 59 and 60. I can see that Debian bookworm/sid is on 59. Not sure how to check Gentoo, but I guess it is also on 59 or 60. I'll add a ticket internally to see if we can add support for 59 and 60.

I can reproduce the issue on Debian Sid, with Spotify and libavformat59, although libavcodec58 is also installed.

BTW why is the client still able to play streamed songs, even with a unsupported libavformat?

Spotify is notorious for having issues with local files. Despite several community issues about issues with local playback, it seems like this will never be fixed. My client periodically crashes while trying to play local files, even if they are in a supported format.

I think it uses Vorbis for streaming, so it would presumably use libvorbis, while libavcodec is used for local mp3/aac files.

Yes, you're right! The only thing I don't understand is why it's able to play Vorbis when it's streamed but not when it's a local file 🤷

Yes, it would be nice if they added support for local Vorbis files (as well as Opus and flac).

Just in case, for those who use flatpak version - check this github issue , since it mentions the current workaround in this post.

FWIW I downloaded and from and put them in /usr/share/spotify. That was enough to make local MP3 files playable on Debian Sid.



Did you download the standalone files or a package ? Can't seem to locate " and" individual files from the link you provided. Thanks !

I downloaded whole packages for libavcodec58 and libavformat58: and

Suggested posts