spotify connect not working properly on linux

Reply
2 people liked this

spotify connect not working properly on linux

klevstul
Regular

i have spotify on three devices:

- my android phone

- my manjaro linux laptop

- my manjaro linux desktop

 

spotify on both my laptop and desktop sees my phone.  my phone sees both my laptop and desktop, but not at the same time. it only sees the one that one last used. my desktop never sees my laptop and my laptop never sees my desktop.

 

i have tried reinstalling, resetting, logging out/in without any help. seems like spotify connect is buggy on linux.

 

Plan

Premium

 

Country

norway

 

Device

nokia 8 (android), manjaro linux desktop, manjaro linux laptop

 

Operating System

android, manjaro linux

 

Screenshot_2018-09-19_17-53-02.png
Screenshot_2018-09-19_17-53-12.png
8 Replies

Re: spotify connect not working properly on linux

hperezf
Casual Listener

Can you check the following on your linux clients (laptop and desktop)?

 

netstat -tanp | grep spotify

Also, can you do a capture of packets between your 2 machines? Just run as root:

 

 

tcpdump -nv -i any host <your-other-host> and port 57621 or port 5353 or port 1900 or 45705 or 38905

 

Once you run this command, open spotify on your desktop, then on your laptop. You'll receive a lot of packages (UDP and TCP).

 

* Tip: Try to run the spotify client with the "--show-console" option, you'll be able to see a lot of GAIA messages. Try to find any "GaiaManager::receiveMsgHandler (new device)" related error or message.

 

 

Re: spotify connect not working properly on linux

klevstul
Regular

sorry for my late reply. i haven't had time to look at my network traffic. thanks for the tips though.

 

however, i have realised that this "feature" is super handy. i can have multiple machines around my house playing different music at the same time, using the same account.

 

this is obviously a bug as you this way easily can share the same spotify account among endless (?) number of linux systems.  if the spotify team are reading these posts i guess they're already working on a fix. if not, i guess there are a lot of linux users that are very happy.

1 person liked this

Re: spotify connect not working properly on linux

NicoHood
Music Fan

Hi,

I have the same issue and it took me the whole weekend to debug the issue. I finally found the root cause of it, please check if it also applies to you:

 

Whenever two linux machines with the same user directory exist (/home/test), they dont see each other through spotify connect. I've set up all my machines recently with the same username and home directory (only the home directory matters, not the username), so Spotify connect is completely broken for me.

If you have 3 machines with the home directories test (2x) and nico (1x) the test machines both see nico, but they dont see each other. I guess this is because some unique ID is being generated based on the home directory path and so they cause a collision.

 

As a workaround you can start spotify with HOME=/tmp/spotify spotify

You must close the not-working spotify and wait 1-3 Minutes before starting the "fixed" version. I guess there is some ip -> clientid cache that must be cleared first.

There is nothing more I can do about this issue, I hope that spotify can help me fix this. I am happy to test any bugfixed version.

 

Edit: Using version 1.0.80.480

 

Edit2: A better workaround is:

ln -s $HOME ~/spotify_fix_$HOSTNAME
HOME=$HOME/spotify_fix_$HOSTNAME spotify &

Cheers
Nico

Re: spotify connect not working properly on linux

klevstul
Regular

thanks for the feedback, nico. i'll try things out and report back.

 

i find it a bit weird that spotify has not prioritised this bug. it's a major loophole if you want to use the same spotify account for numerous of machines.

Re: spotify connect not working properly on linux

klevstul
Regular

thanks a lot, nicohood. your solution worked for me as well. 

 

[klevstul@x270Mjr tmp]$ HOME=/tmp/spotify spotify &

Re: spotify connect not working properly on linux

NicoHood
Music Fan
I also reported this issue via Email. I hope spotify moves this to the bug tracker. The thread is marked as resolved, but it is not. The root cause was found and a workaround suggested. This is definitely a bug, that needs to be fixed!

Re: spotify connect not working properly on linux

klevstul
Regular

yes, you are of course right. it's a workaround, not the solution. i have updated the issue again so it doesn't say it's resolved any longer.

 

i find it very weird that spotify doesn't jump on this bug. as stated earlier, this bug let's the same account being shared among numerous of linux installations.

Re: spotify connect not working properly on linux

VonSieger
Newbie

I get the same issue: When I run Spotify on two computers(Linux) and one tablet. My tablet can only see one of the two computers.

I had the same username/home directory on both machines, now with the workaround it is working again.

 

Best Regards,

VonSieger

SUGGESTED POSTS