'this content is not available' when connected to VPN

Reply

'this content is not available' when connected to VPN

mstojano
Casual Listener

Plan

Premium

Country

Croatia (any VPN country)

Device

Acer Aspire 7750g (laptop, cable connection)

Operating System

Linux Mint 20.1 cinnamon

$ uname -a

Linux *** 5.4.0-74-generic #83-Ubuntu SMP Sat May 8 02:35:39 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

 

My Question or Issue

when connected to VPN service (NordVPN, cable connection, 10mbps dl, 1 mbps ul, ping 17ms) a few errors have been observed.

1. all songs are opaque/gray and 'this  content is not available' pops up when song is double clicked or play is pressed. 'Home' page is responding, and clicking on artist opens a new page.

2. logging out and logging back in produces a proxy/firewall error

 

no problems on windows (8.1, not sure about spotify version there, but latest) with same setup

 

$ spotify --version
Spotify version 1.1.55.498.gf9a83c60, Copyright (c) 2021, Spotify Ltd

 

similar issues were present on linux mint 19.3/4 mate, checked with nordvpn and its not on their side. all other things work normally with nordvpn

 

without VPN connection all works fine

edit: can not attach dum file due to the error: 'The file type (.spotify-dump) is not supported. Valid file types are: jpg, gif, pdf, png, zip, mp4.' when i try to upload

dump should show switching between vpn while it works then stops working, vpn gets turned off and it starts working again. i couldnt find anything that could pin point the moment of the switch

2 Replies

avitt
Visitor

I've been having a similar issue (Ubuntu 21.04), although I was only having trouble while not on a VPN. I configured the connection to my home wifi network to only use Cloudflare's DNS servers (1.1.1.1 and 1.0.0.1), and since then I haven't had any issues with the Linux client.

 

Check out the Cloudflare docs, but you may want to look up Cinnamon-specific instructions. https://developers.cloudflare.com/1.1.1.1/setting-up-1.1.1.1/linux

mstojano
Casual Listener
ty for your input. i've tried to set all the combos from router OS to vpn and still the same thing. after 10 mins of being open all lists gray out
SUGGESTED POSTS