Proxy settings do not work

Proxy settings do not work







Macbook Pro late 2016

Operating System

MacOS 10.13


My Question or Issue


Proxy settings are not working on Spotify Desktop app. Can this be solved?

6 Replies




Hey @the_user.


Thanks for getting in touch!


Could you get us some more info about what you are trying to do? This can help us a lot in trying to find out what is going on.


Please send us over at least the following:


  • Version MacOS
  • Version Spotify (In About)
  • In what kind of environment you are trying to use Spotify
  • Does Spotify work with default settings

Any additional info you might be able to think of would be greatly appreciated! Looking forward to your reply.


Have a nice day!


Hey @Guido,


I've written some of that above already, here's the whole information you requested:


  • Version MacOS: 10.13
  • Version Spotify (In About):
  • In what kind of environment you are trying to use Spotify: Workspace PC behind corporate firewall
  • Does Spotify work with default settings: I've tried using it without proxy successfully, but it will not connect to the internet when the proxy is set in the settings page.


Hey @the_user.


Thanks for getting back to us.


Have you asked your system administrator for assistance yet? It's possible that they have restricted the use of Spotify on your network.


Let us know what they tell you.


Have a nice day!




I have not talked to my sysadmin yet, but I don't think they have blocked spotify especially.

I was under the impression that setting a proxy URL and port should be enough to get this working? I've read in some other thread here that another user had a problem of spotify disregarding the proxy settings and trying to do some connections without using the proxy in the beginning, might this bug still not be fixed?


I am quite sure that I will not get any exceptions added to use spotify, but it should be enough for the in-app proxy settings to work for me to use Spotify, or do I miss something there? I can use the web-player just fine for example, but in my usecase it's not sufficient for me and I would really like to be able to use the native application as it supports more features.


Hey again @the_user,


Since this is inside corporate walls, we can't assure you that it will work, but we'll try our best from here. We still suggest that you speak with your IT department. 


What we can suggest from here is that you reinstall the app on your desktop by following the steps provided here. Also, try with different proxy settings and see if that works. 


Keep us posted 🙂

Suggested posts