Help Wizard

Step 1


Tracks previously linked to local files no longer streamable after deletion of local files

Tracks previously linked to local files no longer streamable after deletion of local files

I can't find a way to get rid of all local files from showing up in my Spotify. I've unchecked both boxes in Preferences but they're still there.


I had The Life of Pablo on my computer as MP3's. Spotify linked this up to the tracks on Spotify, and so when I tried to play a song it would play the local files through Spotify.

I wanted to stream the normal version, so I deleted the local files it was using. Now it says that it cannot play the file, but that I can import it if I have it. However, I can still stream the entirety of The Life of Pablo from my phone, so I know that the songs are available-- Spotify just won't play them from my desktop now.


I can't find any Spotify folders with cache anywhere in Library or Caches or anywhere on my computer. I have reinstalled Spotify twice now nothing is fixed. I feel like I've tried everything. Please help!

6 Replies

Hey @genehayes, welcome the Community.


I am here to help you!

Please follow the steps listed below and tell me how it goes:

  1. Click Spotify in the menu bar then Quit Spotify.
  2. Open Finder then click Go > Library in the menu bar. (You may need to hold the Alt key if Library isn’t visible).
  3. Open Caches and delete the com.spotify.Client folder.
  4. Click the back arrow.
  5. Open Application Support and delete the Spotify folder.
  6. Download and install Spotify.


Thanks! 🙂




Like I said, I can't find any folders or files in Library > Caches. There is no Spotify folder in Application Support either.

I have this exact same problem.  I've posted for help a while ago but I haven't gotten any helpful advice.  It's the same thing every time.  "Uninstall Spotify, locate cache, delete cache, etc. etc."  The cache folders don't appear anywhere.  I've searched all over, including hidden files.  I'm still at a loss.  If you find anything out, please let me know.  I have over 20,000 songs in local files that I can't play from my desktop because of this.  You'd think they would do something about such an obvious problem.

Hey @korryhildebrand & @genehayes,


Sorry for the invenience.

Create a new user account on your Mac and install Spotify there. Then try to put the location of your local songs in the Settings.


Let me know how it goes 🙂

That actually works.  Even using my very same Spotify account on an alternate user account on my desktop, the Local Files area is clear and I can play all the songs that aren't available on my other user account.


Do you have any idea what I'm missing on my main user account?  Some file or files are still remaining somewhere and I just can't find it.  If nothing else, I'm at least relieved that I've gotten this far.  Thanks.

Really happy that it worked for you! 🎉

You can use a third party app for cleanups like ClenMyMac 3 or use DaisyDisk to get a map of your files, where they are and how much space they take 🙂

Suggested posts