[bug report] high quality streaming not working in 0.8.8

Reply

[bug report] high quality streaming not working in 0.8.8

milaszewski
Regular

After I used Spotify for the first time I was amazed with the Premium high quality streaming. 

 

The problem is that with the new version 0.8.8 high quality streaming is not working. It says in the settings it is on, but the sound quality is still 160kbps.

 

Everything is fine when I keep the version 0.8.5 which is installed when you download Spotify for the first time. With high quality streaming and all albums sound almost the same as my 400 original CDs. The problem is that it quickly upgrades itself to 0.8.8 and then the quality drops to 160kbps and all restarting, logging out, switch high quality streaming on/off doesn't help. It always stays 160kbps. If someone has access to ouput meters in their audio interface you can tell you're not getting 320kbps when the peak level of all modern albums is around -4dB instead of around 0dB. Just check the new Biffy Clyro or Muse albums.

 

Please Spotify confirm this as a bug and fix it ASAP.

 

Here is how to recreate the issue:

 

1. Install Spotify. It will run 0.8.5 version when you run it for the first time. Make sure it is a clean install.

2. Turn High Quality Streaming on.

3. Play "The Joke's On Us" by Biffy Clyro - you should hear it in near-CD quality and the peak level should be at around 0dBFS.

4. After Spotify shows you a blue strip with the information about the upgrade, restart Spotify.

5. After the restart you will see the version 0.8.8 (there is the new "follow" feature amongst other things).

6. Play the same song. It will still be the way it was in 0.8.5. It is only the first time after the upgrade when 0.8.8 plays high quality streaming.

7. Restart Spotify again. The high quality streaming is gone for good. You will hear it and the peak level will be down to around -4dB. Now only a clean reinstall can bring the high quality back.

 

I have repeated the same sequence 5 times and it always gives the same results.

15 Replies

Re: [bug report] high quality streaming not working in 0.8.8

Peter__
Community Legend

I have escalated this topic to the community staff for you.
Hopefully someone will be able to look into this soon ;)

Peter

Peter
Spotify Community Mentor and Troubleshooter

Spotify Last.FM Twitter LinkedIn Meet Peter Rock Star Jam 2014


If this post was helpful, please add kudos below!

Re: [bug report] high quality streaming not working in 0.8.8

milaszewski
Regular

There is a workaround to get high quality streaming working temporarly in Spotify 0.8.8

 

1. Make sure Spotify is not running and delete this file: "[User]/Library/Application Support/Spotify/prefs"

2. Run Spotify application

3. Mark "high quality streaming" on and "set the same volume for all tracks" off

4. Enjoy your music in 320kbps and DO NOT restart Spotify. After restarting it will go back to poor quality.

5. Repeat it every time after closing the applications and running Spotify again.

Re: [bug report] high quality streaming not working in 0.8.8

Liam
Community Legend

I'll make an automated batch script to do this ;)

Re: [bug report] high quality streaming not working in 0.8.8

Fred
Community Legend
LiamW I hope you'll post it here with instructions on how to use it.
Right now spotify reminds me of poorly encoded mp3's from the 90's...

/Fred
☆✩✪ Want to help out? Become a Spotify Rock Star today! ✪✩☆
Jag svarar på svenska via pm eller via twitter


Binaural track - listen with headphones with good volume!

Re: [bug report] high quality streaming not working in 0.8.8

David
Spotify Legend

Hello,

 

There may be some confusion about the high quality streaming works on our service.

 

If you play a track on your computer once with the high quality streaming mode selected, this caches the track to your computer. Then, if you restart Spotify, and play that track again, you would play that cached version, which probably would have stored in a high quality. 

 

I've just tested the example track of "The Joke's On Us" by Biffy Clyro on both the latest client and an iOS device, both set to 320kbps quality, and they sound rather compariable to me. For the purposes of full disclosure, I'm using a set of Sony MDR-XB300 headphones. I always find that the high end is the first to go in terms of testing bitrates, especially cymbals on drum tracks. Can I ask exactly what software / hardware you are using to test the bitrates of these track? Also, are the settings in the Preferences menu the same? Ensure that "Set the same volume level for all tracks" is unchecked, too.

Airhorn Enthusiast

Re: [bug report] high quality streaming not working in 0.8.8

milaszewski
Regular

I have gone through all possible cache clearing, reinstalling and other very complex solutions that could possibly fix the problem, but nothing other than sticking to 0.8.5 works. I managed to keep 0.8.5 by modifying some file and folder permissions to prevent the automatic upgrade.

 

My system is OSX 10.8.2

 

I received an email from Spotify confirming that they also were able to reproduce this problem.

 

"Set the same volume for all tracks" is always unchecked but that also gets stuck in the new version. I measure dBFS on my Crane Song Avocet and once the quality drops after the upgrade to 0.8.8, the peak level also drops to -4dBFS (in Biffy Clyro's case and many others) and there is absolutely no way to bring it back to the original 0dBFS level.

 

I think we can safely skip all parts suggesting that I should do/try clearing and reinstalling this and this. The bug is there on my system and being on premium account I am not getting high quality streaming in 0.8.8.

 

I repeat - 0.8.5 works fine.

Re: [bug report] high quality streaming not working in 0.8.8

djschachner
Regular

Does this apply to the Windows version as well, or just the Mac version?

Re: [bug report] high quality streaming not working in 0.8.8

Fred
Community Legend

Since I'm not on a mac, I can't check what happens on there, but on my win8 I'd say the problem gives similar symptoms, but for different reasons. 

I definitely get different streams using 160 vs 320. For some reason though the latest version of spotify caps my frequency output to my soundcards (I've got three different with different chipsets). It's not really noticeable on my low-end system, but highly noticeable on my somewhat better system. As I said earlier, symptoms are the same, but it appears the reasons behind this might be different compared to op's. 

if this is a problem to you, then there are threads in the community on how to roll back to previous versions and block the automatic update - that's what I've done.

☆✩✪ Want to help out? Become a Spotify Rock Star today! ✪✩☆
Jag svarar på svenska via pm eller via twitter


Binaural track - listen with headphones with good volume!

Re: [bug report] high quality streaming not working in 0.8.8

David
Spotify Legend

Hello,

 

We've done some extensive testing on this and unable to reproduce. From logs, we can see that users on 0.8.8 are streaming on 320kbps, with the "High Quality Streaming" mode selected. From the files we tested, we also checked the backend and the actual files themselves, and they were also at 320kbps.

 

The only thing I can think that might be causing this is the "Set the same volume level for each track" setting. Try turning this on for 10 seconds, and you should notice a difference. Turn it off and it should return to normal. 

Airhorn Enthusiast
SUGGESTED POSTS