Announcements

Cant login to account

Cant login to account

jacksoh

Plan

Free

Country

USA

Device

Desktop

Operating System

Windows 10

 

My Question or Issue

I just downloaded Spotify on my pc, and whenever I try to login it says "A firewall may be blocking Spotify. Please update your firewall to allow Spotify. Additionally, you could try changing the currently used proxy settings. error code: auth:3) PLEASE HELP ME I NEED TO STUDY FOR FINALS AND I DONT HAVE MUSIC!!!!

spotify screenshot.JPG
Reply
19 Replies

Ivan

Hey there @jacksoh

 

Thanks for searching for the answer you need here! 
 

We're currently aware of an issue causing the behavior you describe. We suggest you go to this Ongoing Issue and add your vote to it by clicking on the +VOTE

 

It'll also be useful to subscribe via the three-dots menu in the top right corner next to the title. That'll make sure you stay up to date with any relevant updates about this.

 

Hope this helps. Let us know if you have any more questions. 

JoshuaHasian

I figured out how to fix the problem. Somebody on your computer possibly tried to change the Spotify host permission on Windows 10. The possible fix if you are on Windows 10, press the Windows button. Then search for Run. Then type this in on the box

%SystemRoot%\System32\drivers\etc

then you are going to find hosts.Capture.PNG

Double click on it, and then its going to ask what to open it with. You can use any text editor, in this case I'm going to use Notepad.Capture2.PNG

Then when you open it, if you find any text that is related to Spotify, delete it. In my screenshot, I put an example config text, but if there is ANY text that has 0.0.0.0 in front of it, delete it, because it means to block it from the network.Capture3.PNG

Then save it as nothing, NO EXTENSIONS. Capture4.PNG

then its going to prompt to save it on a different location. You can save it to your desktop for convenience. Then when its saved open your desktop file and make sure you have view file extension. Capture6.PNG

its going to ask if you are sure to delete the file extension, press YES.

then move the file back to this location:

%SystemRoot%\System32\drivers\etc

Then a prompt will ask if you want to replace the file, press Replace File on Location. Then make sure its saved, and You are done. try restarting Spotify and log in. I hope this helps 🙂



11125510616

Hi,

 

I also got the same issue : "auth:3" which is different error than the issue you ask us to vote on.

In addition we are using Windows (10, for me).

I also tried all the workarounds suggested on the other issue, whith no success.

Guessed also that the issue was linked to my facebook account, so I tried to build a free account from an e-mail but I get exactly the same problem.

 

Could you please support ?

kind regards,

2020-04-10 18_59_23-Spotify.png

Ivan

Hey there @11125510616

 

Thanks for jumping in to the thread. 

 

You can still give your vote on the Ongoing Issue page in question. The number included in the error message shows up as different to many users, but we're still investigating this issue as firewall-related. 

 

That's why you can feel free to contribute to this thread as you're experiencing the same issue. 

 

Hope this helps. We'll be here in case you need any further help with this. 

lelecaps

Thanks man! It solved my issue!

jennervk
why did i have to search so long through these useless responses from spotify, when this random user has the exact solution written up so well, thank you kind sir

iNick1

Hi there, just posting on this forum for the equivalent solution on Mac. 

 

Open Finder 

In the Menu Bar select Go and then 'Go to Folder' 

Enter: /private/etc/hosts

 

Locate the file called 'host' and drag to desktop 

Open the file and replace the text with: 

 

##
# Host Database
#
# localhost is used to configure the loopback interface
# when the system is booting. Do not change this entry.
##
127.0.0.1 localhost
255.255.255.255 broadcasthost
::1 localhost

 

Save the file

Copy this back into the /private/etc/hosts location and select 'replace' when the conformation shows. 

 

Restart/Reinstall Spotify 

 

 

 

 

Mario

Hey @iNick1,

 

Thanks for posting this here in the Community.

 

As a heads-up, we have an Help Board section focused on the Mac desktop area and it'd be awesome if you'd contribute to it by clicking here in case you have any questions or solutions for all our Mac desktop users 🙂 

 

Hope you'll find this info useful. Don't hesitate to let us know if there's anything we can help with.

 

Have a nice (and a safe) day!

Mario Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

K3niX

I didn't have the extension how can do it? 

jayasimha
Thanks, man. You saved me.

JoshuaHasian
Thanks for making the Mac equivalent man!!!

JoshuaHasian
What do you mean by not having the extension?

UnoReverseCard
This fixed it.

_cdsu-5tttf4c

This works, Thanks! 😄

Cloud1

Didn't work at all for me since it was already in the hosts file.

lauraklp
I had the same issue. I have McAfee on my pc.
I turned off the Firewall, logged in, and turned on the firewall again. Then McAfee sent a message "Do you want to allow this application?" And I clicked "Allow" and now it's working.
My advice is: try to turn off the firewall... and don't forget to turn on again lol

dotgomes

Thanks, I do this and works for me.

 

For other that still having this problema, go to "Start" menu and type Firewall, select the option "Firewall & network protection"

dotgomes_0-1617635630780.png

Click on Public network and turn off the firewall. Windows will ask if you want to turn off, click on "Yes". Then you will be able to log in.

 

Once will log in, try to play some music. After this go again and turn on the firewall. 

melinabadii

Hi

Thanks for your answer

Unfortunately I still have the problem... in the Hosts section, mine was written like yours until "Local Host" (the last # line)

And after that I have nothing. You said to delete any 0.0.0.0. but mine has no code under the last line of local host. not any codes. not even 0.0.0.0 and not anything related to Spotify.

I backspaced once (to make a little change under the last line) and did the rest exactly as you said (save on desktop, no exten., replacing)... it still didn't work

I have allowed Spotify in firewall (private & public), turned my firewall off, uninstalled & reinstalled again, changed proxy (auto/no proxy)... nothing helped

I hope you can help me

Thanks

Alex

Hey @melinabadii,

 

Thanks for the post.


Can you try connecting your PC to another network, like a mobile hotspot and check whether the app works like that? This will help us check whether the issue is network related.

 

Keep us posted.

AlexModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Suggested posts

Env: prod