Is it possible to use spotify with a 5.1 setup?

Solved!
Reply

Is it possible to use spotify with a 5.1 setup?

Swindle
Newbie

Tried googling and looking over the forums however I can't seem to find an answer/solution.

 

I have a 5.1 speaker setup (5 speakers + a sub) however spotify sounds only use 2 speakers + the sub. This is natural for most audio files, however I was wondering if there was a way of converting it to 5.1.

 

I usually use a program called Foobar which converts mp3 files into 5.1 when you play them, making sound come out of all speakers, however there is no option for this within spotify.

 

Has anyone found a solution to this?

2 ACCEPTED SOLUTIONS
Solution!

remusjohn
Casual Listener

Hey everyone,

 

I think i found the solution to the problem wherre "speaker fill" does not help.

 

you can force the spotify app to ignore it's own audio settings by adding "--disable-audio-output-resampler" to the shortcut path"

 

go to the properties of your shortcut of spotify (on win 8, you can find your shortcut in C:\Users\[yourname]\AppData\Roaming\Microsoft\Windows\Start Menu\Programs)

 

add quotationmarks (") at the begin and the end of the path than ad a space and "--disable-audio-output-resampler"

 

apply and exit.

 

this should, in combination with speakerfill, enable all of your speakers by some version of virtual surround.

 

greetz

David

View solution in original post

Solution!

alanmw1
Newbie

It's a little bit different now, its voice meeter Banana. New link, https://www.vb-audio.com/Voicemeeter/banana.htm

 

Same method, just looks a little different. Click A1, add your speakers, click where it says "Normal Mode" and change it to stereo repeat.

 

If you are having issues, make sure the VoiceMeeter Aux is the primary audio device.

 


@thomasb2602 wrote:

I have found a fix for mine!

Download Voicemeeter:

http://vb-audio.pagesperso-orange.fr/Voicemeeter/

then install it, and reboot your pc.

go to playback devices.

And set up the vooicemeter app as 7.1, but untip the side pairs if u have 5.1 . See photo

fix2.PNGfix3.PNG

And just click next, next, finish.

 

Then setup your speaker in Voicemeeter. See photo

 fix.PNG

 

Now we need to let it start every bootup, so we need to put a shortcut in the startup map.

Goto Start (windows logo)

All programms

Go to the Startup map, and right click than click on open.

Than go back to all programs, and find a map called VB Audio.

Open the map, also the voicemeeter app.

Copy the app called, Voicemeeter, in the Startup map that we just opend.

DONE! I hope it worked!!


 

View solution in original post

49 Replies

thomasb2602
Gig Goer

As kachunkachunk said,

"If you're using an X-Fi, just use CMSS 3D. The Soundblaster suite generally does a multi-channel re-matrix pretty well."  Remember to aslo tick off the option in spotify called "Hardware acceleration" ad the bottom of the advanced settings! U will get 5.0 working, but still no subwoofer will work with it.. so fur subwoofer use I still need voicemeeter. Maybe someone will get it working without voicemeeter and only the CMSS 3D.

*edit*

After setting my speakers from 7.1 in the creative menu to 5.1 i got my subwoofer working, even on yotube it works now.

droid_hunter
Newbie

If you use a receiver via hdmi, all you got to do is go to audio settings in windows and set your playback device to STEREO, then on the receiver choose to upmix the sound to dolby surround or dts neural x (new upmixers) or pro logic II (old)

 

Remember to switch back to 5.1 or 7.1 BEFORE starting up a game or else the game will be stereo upmixed as well, and not native surround sound.

 

For sound cards, you will have to use the driver settings of the particular card to upmix the sound.

seanpatrick76
Gig Goer

Using PLiix or dts etc. is a poor substitute for speaker fill.  Try using Deezer with Microsoft Edge and you'll see how much improved it is over any of those matrixed playback algorithms use by receivers.  This used to be able to be accomplished by using Spotify with Edge browser, but the functionality has been lost for several months with no update, leaving you with the option of using KODI to upmix 2 channel for a similar result, or quitting Spotify and using Deezer. 

 

 

 

CEDP99
Newbie

Only disable "hardware aceleration" in spotify settings and now sound all the speakers. I hope that it help us. Sorry for my english I  speak spanish normally.

thomasb2602
Gig Goer

I have found a fix for mine!

Download Voicemeeter:

http://vb-audio.pagesperso-orange.fr/Voicemeeter/

then install it, and reboot your pc.

go to playback devices.

And set up the vooicemeter app as 7.1, but untip the side pairs if u have 5.1 . See photo

fix2.PNGfix3.PNG

And just click next, next, finish.

 

Then setup your speaker in Voicemeeter. See photo

 fix.PNG

 

Now we need to let it start every bootup, so we need to put a shortcut in the startup map.

Goto Start (windows logo)

All programms

Go to the Startup map, and right click than click on open.

Than go back to all programs, and find a map called VB Audio.

Open the map, also the voicemeeter app.

Copy the app called, Voicemeeter, in the Startup map that we just opend.

DONE! I hope it worked!!

Solution!

alanmw1
Newbie

It's a little bit different now, its voice meeter Banana. New link, https://www.vb-audio.com/Voicemeeter/banana.htm

 

Same method, just looks a little different. Click A1, add your speakers, click where it says "Normal Mode" and change it to stereo repeat.

 

If you are having issues, make sure the VoiceMeeter Aux is the primary audio device.

 


@thomasb2602 wrote:

I have found a fix for mine!

Download Voicemeeter:

http://vb-audio.pagesperso-orange.fr/Voicemeeter/

then install it, and reboot your pc.

go to playback devices.

And set up the vooicemeter app as 7.1, but untip the side pairs if u have 5.1 . See photo

fix2.PNGfix3.PNG

And just click next, next, finish.

 

Then setup your speaker in Voicemeeter. See photo

 fix.PNG

 

Now we need to let it start every bootup, so we need to put a shortcut in the startup map.

Goto Start (windows logo)

All programms

Go to the Startup map, and right click than click on open.

Than go back to all programs, and find a map called VB Audio.

Open the map, also the voicemeeter app.

Copy the app called, Voicemeeter, in the Startup map that we just opend.

DONE! I hope it worked!!


 

View solution in original post

thomasb2602
Gig Goer

U now can choose between banana and Voicemeeter. I myself find voicemeeter (normal one) a bit more user friendly. But if u want to record Ur voice with voice meeter, than banana is the best option for U. Thanks for bringing it up!

tactiic
Casual Listener

@thomasb2602 thank u so much

thomasb2602
Gig Goer

I'm glad that the tutorial helped u with fixen Ur problem!

tactiic
Casual Listener

.

Kashan
Regular

Man I owe u a big one. Thanks a lot !!!!!! 

thomasb2602
Gig Goer

Nice that you found a fix!

Baggers1982
Newbie
The only way I can get it to play in 5.1 is to hook my macbook up to my TV and then surround sound up to my TV via Optical. The TV converts it to 5.1. Hope that helps if it hasn't already said before.
Solution!

remusjohn
Casual Listener

Hey everyone,

 

I think i found the solution to the problem wherre "speaker fill" does not help.

 

you can force the spotify app to ignore it's own audio settings by adding "--disable-audio-output-resampler" to the shortcut path"

 

go to the properties of your shortcut of spotify (on win 8, you can find your shortcut in C:\Users\[yourname]\AppData\Roaming\Microsoft\Windows\Start Menu\Programs)

 

add quotationmarks (") at the begin and the end of the path than ad a space and "--disable-audio-output-resampler"

 

apply and exit.

 

this should, in combination with speakerfill, enable all of your speakers by some version of virtual surround.

 

greetz

David

View solution in original post

Alacaster
Newbie

Sir. You are a genious

Hamish319
Newbie

If your wondering where it is exactly where you add "--disable-audio-output-resampler"

Its... Right click on the Spotify shortcut and click Properties

Then on that screen it shows

Start in

Shortcut key

Run

Comment

and all i did was add "--disable-audio-output-resampler" to the comment box and that worked 🙂

spotify.png

danielpaavola
Newbie

Why does it still not work for me? I did it all, but Spotify still refuses to give me my mustic in 5.1.

thomasb2602
Gig Goer

Sorry for my late response but, does this work?

 

I have found a fix for mine!

Download Voicemeeter:

http://vb-audio.pagesperso-orange.fr/Voicemeeter/

then install it, and reboot your pc.

go to playback devices.

And set up the vooicemeter app as 7.1, but untip the side pairs if u have 5.1 . See photo

fix2.PNGfix3.PNG

And just click next, next, finish.

 

Then setup your speaker in Voicemeeter. See photo

 fix.PNG

 

Now we need to let it start every bootup, so we need to put a shortcut in the startup map.

Goto Start (windows logo)

All programms

Go to the Startup map, and right click than click on open.

Than go back to all programs, and find a map called VB Audio.

Open the map, also the voicemeeter app.

Copy the app called, Voicemeeter, in the Startup map that we just opend.

DONE! I hope it worked!!

thomasb2602
Gig Goer

if mine did'nt work you should test your speakers. Maybe a bug in your windows. Bequase voicemeeter just sets 2.1 to 5.1. There is no special effects, it just lets your pc think the back speakers are the same as the front.

andix84
Casual Listener
Did you try with vb-audio? It worked for me.
SUGGESTED POSTS