Announcements

Not showing album artwork of certain albums.

Solved!

Not showing album artwork of certain albums.

Spotify isn't showing the album artwork of certain albums (see attached screenshot for an example) and it's driving me nuts. I tried uninstalling and reinstalling several times, but nothing changed. I'm running the Windows Store version.3.JPG

 

Reply

Accepted Solutions
Marked as solution

I had this exact same issue, it started a a few weeks ago. 

 

I found that it only happened at work. I changed my network settings in Spotify to use a proxy, bypassing my works webfiltering, and the art came back.

 

To get to the proxy settings go to Spotifiy prefrences, scroll all the way down, then click on "Show Advanced Settings", scroll all the way down until you see Proxy. You'll need access to a proxy to bypass the webfiltering.

 

Just for refrence, we use McAfee web filtering for enterprise, with HTTPS inspection.

 

Hope that helps, or at least shine some light on what may be going on.

View solution in original post

7 Replies

That's an album from your local library. Unless it knows the album and can download the art for it, it won't be able to show the art for it, as far as I'm aware.

No, the albums that aren't showing are all from Spotify.

I have the exact same problem on my Windows 10 PC.

 

The music plays normally but all albums in my library are shown with a black cover, in all sections (Albums, Artists and Recently Played).

 

I tried re-installing Spotify, rebooting, logging off and on, but nothing fixed the problem.

 

Maybe the proxy on our company network is to blame? At least the music plays fine...

SpotifyNoArtwork.jpg

I still don't have covers for the albums in my collection using the Window 10 desktop app, but I noticed that the covers are shown properly when I visit an artist's page (see GIF below).

 

As a side note, the web app works perfectly and all the album covers are shown, so I decided to use it instead of the desktop app.

SpotifyNoCovers.gif

Same here, please fix.

Screenshot_1.png
Marked as solution

I had this exact same issue, it started a a few weeks ago. 

 

I found that it only happened at work. I changed my network settings in Spotify to use a proxy, bypassing my works webfiltering, and the art came back.

 

To get to the proxy settings go to Spotifiy prefrences, scroll all the way down, then click on "Show Advanced Settings", scroll all the way down until you see Proxy. You'll need access to a proxy to bypass the webfiltering.

 

Just for refrence, we use McAfee web filtering for enterprise, with HTTPS inspection.

 

Hope that helps, or at least shine some light on what may be going on.

Worked for me thanks!

Suggested posts