Web player not working in Chrome after logging in

Reply

Web player not working in Chrome after logging in

silverface
Casual Listener

The web player is showing a blank black page for logged-in users on Chrome. The console print-out reads:

 

(first line):

Uncaught TypeError: Cannot read property 'then' of undefined
at Object.onEnter (web-player.e960f069.js:1)
at Array.o (web-player.e960f069.js:1)
at web-player.e960f069.js:1
at web-player.e960f069.js:1
at l (web-player.e960f069.js:1)
at t.a (web-player.e960f069.js:1)
at o (web-player.e960f069.js:1)
at runEnterHooks (web-player.e960f069.js:1)
at web-player.e960f069.js:1
at o (web-player.e960f069.js:1)


(second line):

open.spotify.com/:24 Refused to execute inline script because it violates the following Content Security Policy directive: "script-src 'self' 'unsafe-eval' open.scdn.co www.google-analytics.com cdn.ravenjs.com vt.myvisualiq.net www.gstatic.com". Either the 'unsafe-inline' keyword, a hash ('sha256-exNIbRoBufGA8Xw81IIBBDk1C1yh5NkucdznLehlx2g='), or a nonce ('nonce-...') is required to enable inline execution.

 

(third through fifth lines):

SpotifyController.js:1 STREAMKEYS-INFO: Attached listener for c
SpotifyController.js:1 STREAMKEYS-INFO: SK content script loaded 
SpotifyController.js:1 STREAMKEYS-INFO: Player state change
2 Replies

Re: Web player not working in Chrome after logging in

Ruxel
Regular

There are a couple threads on this right now. Seems to be a widespread issue. Nothing from Spotify yet.

Highlighted

Re: Web player not working in Chrome after logging in

simchajra
Newbie

Been having this issue too since yesterday. Coincidentally also got a big windows 10 update right before that though I can't tell if that could be connected.

 

So far I can use the webplayer if I clean the cookies related to spotify. But if I dare to refresh the page this issue keeps happening. I can see the webplayer for a second but quickly shows a blank page (webplayer's grey background color and nothing more). If I delete the cookies again the issue is fixed until I refresh once more. This also happens in incognito mode in the Chrome browser.

 

If I check the console in Chrome I'm getting the exact same error lines as shown above.

 

Refused to execute inline script because it violates the following Content Security Policy directive: "script-src 'self' 'unsafe-eval' open.scdn.co www.google-analytics.com cdn.ravenjs.com vt.myvisualiq.net www.gstatic.com". Either the 'unsafe-inline' keyword, a hash ('sha256-exNIbRoBufGA8Xw81IIBBDk1C1yh5NkucdznLehlx2g='), or a nonce ('nonce-...') is required to enable inline execution.
SUGGESTED POSTS