Amazon Echo name changed to some serial number

Amazon Echo name changed to some serial number

Zyla

Plan

Premium

Country

Hungary

Device

Amazon Echo Dot 3gen

Operating System

Windows 10

 

My Question or Issue

Since yesterday when I request the available devices via API Reference, I receive this:

 

"id": "d0e0c8da-1a4b-4b72-b7ff-4f089fd41d92",
"is_active": true,
"is_private_session": false,
"is_restricted": false,
"name": "d0e0c8da-1a4b-4b72-b7ff-4f089fd41d92",
"type": "Speaker",
"volume_percent": 36

However when I open spotify app on my phone or the windows app on my computer, then the name is correct. (It should be "Echo Dot")

 I have tried to rename and device and deregister the device and reconfigure in the alexa app, but it did not help.

Reply
62 Replies

Hubo
Hey there, thanks for reaching out!

Hmm, let's look at what's going on. Did this recently change or is this something that happened as long as you've used the API? Also, is there any other parameter that gives the correct name of the device in the response? Keep me posted!

Have a great day,
Hubo
HuboSpotify Star
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

Zyla

Dear Hubo,

Thank you for your reply!

No, It just happaned yestarday before. My Home Assistant (connected to Spotify) are managing my speakers and plays music according to where I am located.

Suddenly it notified me, that an echo dot is not available. I look into it, and noticed that it was renamed. This change was made that day, otherwise I must have been noticed earlier.

Laszlo

WazoAkaRapace
Hey, got the same issue here.
The spotify API is reporting name = id, but the Spotify App is showing the right name...
It started 2 or 3 weeks ago as my homeassistant start showing the id instead of name...

franfos

Hi,

I think it's related to the latest Echo Dot firmware version.

I have 3 Echo Dot's, one of them tuned off since some days ago.

I realized the wrong name in Home Assistant, and when I turned on the third Echo Dot, the name was correct.

I checked the firmware version, and it was different from the other two. After a while, the third Echo updated, and then the name also appeared wrong in HA.

WazoAkaRapace

Hi,

 

 

 

So, maybe we should post the same kind of topic to an Amazon community forum as well...

tpicon

Hi

I'm facing the same problem here

 

With Echo show I don't have this behaviour

And with former version of Echo dot doesn't happen also

 

The problem is with the new Echo firmware

I already send a message to Amazon Engineer but nothing until now

 

I will post here If they answer

tiagopicon-br

Hi, this is what I got from Amazon Support yesterday

 

Hi there,

 

Thank you for following up.

 

As much as I would like to help, the Spotify API is not owned or supported by Amazon. Unfortunately, we are unable to provide information regarding this issue. Please follow up with Spotify support for more details.

 

So, please Spotify, check this!!

franfos

Well, it looks it’s an issue related to Amazon, not Spotify. Before the firmware update, it was working ok, and it’s also working properly in other devices.

I guess we’re not going to have success if they blame each other.

tiagopicon-br
Agree franfos...

And here in the company we pay to use the Amazon support (almost $30 per month) and they answered this
It's awful

Bart1909

Any news on this?

I'm also facing this problem. I'm getting the users active devices in an Alexa Skills and now receiving sometimes the serial-numbers / IDs of the devices at its names.

This is annoying because I'm "saying" the device name to the customer via the skill and now it is reading the number..

 

I didn't changed anything in the code and it is only on some devices, not all.

 

Best wishes

 

 

tpicon

Hi Bart1909

 

Same here! In my opinion it's a Echo firmware bug because with the previous version this doesn't occurs

 

We are facing serious problems with our costumers 

 

 

chiptune
The thing is Spotify app can show these names ok. So there seems to be some inconsistency with its API.

WazoAkaRapace
We should point this out to Spotify team. How do we contact them ? Is there an other way to report those kind of issue ?

tpicon

Chiptune, 

 

I believe it's on both side (Amazon and Spotify)

Why Amazon?

Because with previous firmware of Echo doesn't happen

 

Why Spotify?

I don't know how, but they have the 'names' of the Echo's otherwise they woulnd't show the correct names in their app

 

We've been trying a workround here but nothing until now

 

 

tpicon

WazoAkaRapace, 

 

I think we should contact them, but I don't have the path

 

If anyone knows please tell us

ohej

Thanks for reporting this. I've raised this with the team and they are investigating. I'll report back once we learn more.

ohej
Update: The issue has been confirmed and is being investigated further. I'll report back when I receive an update on a fix.

ohej
A fix has been rolled out today, can someone in this thread confirm if this has resolved the issue?

tpicon
Yes, I will test and post the result here

Tks!!

Suggested posts