Announcements

Developer Site Web-API reference Docs not working

Developer Site Web-API reference Docs not working

Device

Iphone 6 - Safari

 

My Question or Issue

When accessing the page at 

https://developer.spotify.com/documentation/web-api/reference/ 

 

it asks you you to select an endpoint from the drop down menu.   As soon as I do nothing happens and there is no “go” button.

 

see attached photos

655E7AD8-7F5A-4F9D-98B4-0DEFA6DBB4C3.png
8554F30D-C65E-4C4D-AAAF-01B9C2CDC5BC.png
Reply
10 Replies

thanks for reporting this - it has now been fixed and should work well.  

Nope still not working

Update: it looks like it has been fixed.

Not a fan of the new Reference page - the old docs were great 

The new version changed the categories in a way that doesn't make sense ("Get Recommendations" is now under "Artists" as "Browse" category is missing, even thought the endpoint return tracks and takes seed artists, tracks, and genres)

Important documentation is now missing on using filters in /search ?q= queries like "track:<track>+ artist:<artist>". Can be partially inferred from /search ?type param description, but have to guess that categories. 

Also confusing that the old docs style and categories still live on the Console section: https://developer.spotify.com/console/browse/

The old Reference Docs were great, bring them back 🙂 

Just tried it gain and it STILL isn’t working 

 

Also just trying on my Mac and when ingo

to the Docs menu at the top the options window drops down, as soon as I move my cursor downwards to select something the whole “drawer” menu disappear and I can’t select anything.

 

Poor testing before this was rolled out!!!

 

   

On my Mac I was able to get to the reference page by clicking on the main top menus that were available.  And then selecting options on the next page and then again.

 

after arriving to the API/reference page on Mac on Safari.   There is no “Select You Section” element.

 

image.jpg

Still not working

Still on working on IOS or my Mac safari Browser

Still not working on iOS 

Suggested posts