Help Wizard

Step 1


Intermittent 404s Getting Playlist Tracks via API

Intermittent 404s Getting Playlist Tracks via API

Starting about two days ago, I began to see intermittent 404s when getting playlist tracks via the Spotify API (*/tracks).  I have seen this when iterating over large playlists via the offset and limit parameters, collecting 100 tracks at a time.  Re-sending some of the failing requests (identical requests) can yield 200s at a later time.


It's possible this is an improperly responding rate limit (that shouldn't be returning 404s) or some sort of load-balancing / request routing confusion.


Example URL:


Interesting Response Headers:

'Content-Length': '0',

'server': 'envoy',

'Via': 'HTTP/2 edgeproxy, 1.1 google',

'date': 'Mon, 21 Mar 2022 03:40:18 GMT',

11 Replies



Thanks for reporting this - we'll investigate and respond when we get to the bottom of it.

For whatever it's worth, I have not noticed this behavior in roughly the last 24 hours.

Any updates on this topic? I'm having the same issue since 10th of april.

Playlist track requests and track info requests randomly return a 404 whilst the ID exists. If I send the same requests on a later moment, a 200 response is returned.


I'm using my app for several months without problems untill now.

Same here, I keep seeing random 404 when requesting artists, albums and tracks.


Simply adding a retry in the code, just after the failed request solves the issue 🤷🏽 So seems like an API issue.

I am also getting the same behaviour when trying to get artist albums, the behavior is random/flaky returning 404's.
Could you please investigate ?
This is only recently happening.

If you also had the problem, please click the "Me too" button on top.

That's how I solved it for now as well, 10 retries for each request. Sometimes even 10 404's returned in a row. If I perform the same request again a few minutes later, 200 returned.

I am also tempted to solve it with retrying 404 but it's clearly a bug of course...

Original reporter here.  Can update that this issue went away for a while around three weeks ago, but the error behavior is back for me as of about two days ago.

Im having the same problem with the endpoint to get playlist

I am facing this issue as well.  Specifically on this track
  "error": {
    "status": 404,
    "message": "analysis not found"


The ID has worked for me fine for the past couple of months. I do some playlist analytics via Qlik, and this sudden 404 is breaking my application. 



Suggested posts