Announcements

Searching for podcasts not returning results

Searching for podcasts not returning results

Hi, thanks again for these new podcast api endpoints!

 

I'm having an issue using the web api to search for podcasts. When I use an access_token from the client_credentials flow, I'm not getting any results. However, when using the tool on spotify developer console page and oauth token, the same query retrieves results.

 

Are we able to use the client credentials access token on the search api endpoint for shows? It works for all the other types, just not 'show'.

 

Thanks, let me know.

Reply
14 Replies

Hey @musicfan2424, thanks for reaching out here!

I'd love to take a closer look. Could you let me know the exact query you're calling the API with (without access token)? Also, what is the response you're receiving? Keep me posted!

Have a good one,

Hubo

HuboSpotify Star
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

Hi, search request using access_token from client credentials flow.

{
"shows": {
"href": "https://api.spotify.com/v1/search?query=Bill&type=show&offset=0&limit=1",
"items": [
null
],
"limit": 1,
"next": "https://api.spotify.com/v1/search?query=Bill&type=show&offset=1&limit=1",
"offset": 0,
"previous": null,
"total": 3832
}
}

Same query with oauth token

{
"shows": {
"href": "https://api.spotify.com/v1/search?query=Bill&type=show&offset=0&limit=1",
"items": [
{
"available_markets": [
"AD",
"AE",
"AR",
"AT",
"AU",
"BE",
"BG",
"BH",
"BO",
"BR",
"CA",
"CH",
"CL",
"CO",
"CR",
"CY",
"CZ",
"DE",
"DK",
"DO",
"DZ",
"EC",
"EE",
"ES",
"FI",
"FR",
"GB",
"GR",
"GT",
"HK",
"HN",
"HU",
"ID",
"IE",
"IL",
"IN",
"IS",
"IT",
"JO",
"JP",
"KW",
"LB",
"LI",
"LT",
"LU",
"LV",
"MA",
"MC",
"MT",
"MX",
"MY",
"NI",
"NL",
"NO",
"NZ",
"OM",
"PA",
"PE",
"PH",
"PL",
"PS",
"PT",
"PY",
"QA",
"RO",
"SE",
"SG",
"SK",
"SV",
"TH",
"TN",
"TR",
"TW",
"US",
"UY",
"VN",
"ZA"
],
"copyrights": [],
"description": "HBO and The Ringer's Bill Simmons hosts the most downloaded sports podcast of all time, with a rotating crew of celebrities, athletes, and media staples, as well as mainstays like Cousin Sal, Joe House, and a slew of other friends and family members who always happen to be suspiciously available.",
"explicit": true,
"external_urls": {
"spotify": "https://open.spotify.com/show/07SjDmKb9iliEzpNcN2xGD"
},
"href": "https://api.spotify.com/v1/shows/07SjDmKb9iliEzpNcN2xGD",
"id": "07SjDmKb9iliEzpNcN2xGD",
"images": [
{
"height": 640,
"url": "https://i.scdn.co/image/95356f7f3909283f35ca3caeaf4dfb474f1078ae",
"width": 640
},
{
"height": 300,
"url": "https://i.scdn.co/image/9c84edb997acbb6546de2ec214810335f06820be",
"width": 300
},
{
"height": 64,
"url": "https://i.scdn.co/image/4d09e819b6b96016673e9c00cf6e367d577d1bc1",
"width": 64
}
],
"is_externally_hosted": false,
"languages": [
"en"
],
"media_type": "audio",
"name": "The Bill Simmons Podcast",
"publisher": "The Ringer & Bill Simmons",
"type": "show",
"uri": "spotify:show:07SjDmKb9iliEzpNcN2xGD"
}
],
"limit": 1,
"next": "https://api.spotify.com/v1/search?query=Bill&type=show&offset=1&limit=1",
"offset": 0,
"previous": null,
"total": 3832
}
}





I also just noticed if you use the access_token from client credentials flow and change the query to type=show,episode
https://api.spotify.com/v1/search?q=Bill&type=show,episode&limit=1

It does return results for the podcast. For some reason just the show type alone doesn't work properly with this client credentials access_token?

Hey @musicfan2424,

 

Hmm, that’s indeed quite odd. I’ll pass this along to the right folks. Fingers crossed, this’ll be fixed soon. I’ll keep you posted!

 

Thanks for your patience!

 

Have a good one,

Hubo

HuboSpotify Star
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

Which error are you getting? 401?

I've had this same issue. There is no error. The call is successful and gets a response. The problem is everything returned in the "items" array is null. I can use the exact same credentials and search for artists, albums or tracks and it works properly. Only the podcast related search types "show" and "episode" aren't working.

And how does your code query look like?

I'm getting the same issue. It's a 404 and the response body is:

{
"error" : {
"status" : 404,
"message" : "non existing id"
}
}

Hey @ponny, thanks for coming to the Community!

 

It looks like you're having a bit of a different issue here. I'd love to take a closer look. Could you let me know the exact request you're making to the Spotify API? Let me know!

 

Have a good one,

Hubo

HuboSpotify Star
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

Hey @arboralto,

 

Thanks for letting me know! I'll pass this on to the right folks. Hopefully, it'll be fixed soon!

 

Thanks, have a great day!

Hubo

HuboSpotify Star
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

This issue still persists. Any update on a fix for it?

I've found that you need to specify the market with the API call. The docs say it's optional, but it appears to be required for show or episode searches.

Had the same issue, needs &market= on the url.

The issue still persists, adding market did the trick.

Suggested posts