Announcements

Help Wizard

Step 1

NEXT STEP

FAQs

Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...

VIEW ALL

Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...

VIEW ALL

iOS 16 Spotify widget not loading (black)

Solved!

iOS 16 Spotify widget not loading (black)

I have added the Spotify widget to my Home Screen and it was perfect for a few days but then it went black and never loaded. I have rebooted my phone, logged out and in as well as reinstalling the app. Nothing works. I hope this can get fixed. Thanks

 

Plan

Premium

Country

England

Device

iPhone 11

96FF8BD7-DD3F-4904-A1E8-17094408F190.jpeg

Reply

Accepted Solutions
Marked as solution

Spotify Premium

Device: iPhone 14 Pro Max

OS: iOS 17.3.1

Spotify ver: 8.9.19.571

 

I also experienced the blank Spotify widget issue this week. I solved my issue by doing the following:

 

1) Remove the Spotify widget.

2) Restart the phone.

3) Add the Spotify widget.

 

I hope this helps👍.

 

 

 

View solution in original post

42 Replies

Hey @MrRobot135,

 

Thanks for posting in the Community and welcome.

 

In this case, we'd like to gather some additional info. Would you mind sending us the exact Spotify version you are currently running on the affected device?

 

On another note, and just to confirm, is this happening no matter what content you're playing in your device or does it happen with a specific playlist album? If not sure, it'd be awesome if you could check.

 

Lastly, did you notice if this started to happen after a specific event such as an OS update? If yes, please send us the details.
 

Keep us in the loop!

AlejaRModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.

Hello, thanks for getting back so quickly.


My Spotify version is 8.7.94.551 and my phone is on iOS 16.2

 

this occurs with every playlist or album and sometimes it doesn’t even load which is what is happening at the time of writing.

 

It occurs with low power mode on and off too

7AEF7883-230D-4878-8E40-EA82A3D86F36.jpeg

It was working fine while I was on the same os version and I have not changed any settings to do with the phone.

 

Thanks a lot.

Hey @MrRobot135,

 

Thanks for your reply and for the info shared.

 

In this case, we'd like to continue investigating this further. For starters, is this happening when you open a different account in the affected device? If not sure, it'd be awesome if you could check. You can ask for the account of a relative or a friend to open it in your device and check.
 

On another note, is this happening over WiFi? 3G/4G? Both? Do you notice any difference if you switch the internet red you're using? Do you use a VPN? If yes, try switching it off.
 

Keep us in the loop!

AlejaRModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.

Hello,

 

It seemed to be an issue in both a Wi-Fi connection and on data. I do not use a VPN

 

When I logged into a family members account (Spotify free account) it seemed to work perfectly. I logged back into my account and seemed to work perfectly.

 

I find this slightly odd as I had all ready logged out and in as well as logging in again after re installing the app. Maybe it was the signing into another account that helped.

 

Thank you for allowing me to have a great first experience on Spotify support and replying quickly.

 

Have a great day!

Hey @MrRobot135,

 

Thanks for your reply 🙂

 

We really appreciate you keeping us posted about this inconvenience and we're happy to know that is now fixed. If the app starts to behave again, you can log out and log in twice onto your account, so the system will refresh. If this doesn't do the trick, you can always reach out and we'll help you 🙂

 

If anything else comes up, the Community will always be here for you.

AlejaRModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.

Thank you 😊

Hi, I’m also having this issue. Logging in and out multiple times, deleting the app and the widget, restarting my phone all haven’t worked. Logging into another account fixed it for that account, but logging back into my main account has not fixed it after switching back.

The widget feature seems to be broken for iOS 16. This issue has happened multiple times and seems to come and go. The widgets will fail to update in real time. Then go from outdated info to all black with the most recent artist and placeholder images to just black and grayed out. Logging out of the app twice doesn’t fix the issue. Deleting and reinstalling the app doesn’t work. Restarting my device hasn’t helped, neither has updating to the most recent iOS version. The only way to get the widget working appears to be signing into another account(free account was tested). However signing out of that account and back into my main account just brings the issue back.

8E069876-BD78-44E4-92FF-B522DD19F6DB.jpg
EEF46DCA-4477-429B-BD91-43B36DFA71FE.jpg
069E55BE-1DC8-47A3-8AF5-A78731D001F7.jpg

Hey @JakeMor,

 

Thanks for reaching out.

 

Can you please let us know your device model, OS version and Spotify version, so we can forward this to the relevant team?

 

Looking forward to your reply.

MihailYModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Mine is also like that my device model is iphone 11 and I’m on ios 16.3 (the most updated version)

I have same issue as @JakeMor for iphone 14 pro with latest version

Hey @yilmazozkn,

 

Thank you for you reply in this thread.

 

In this case, we'd like to gather as much info as possible. Would you mind letting us know what troubleshooting you've tried so far? This'll help us avoid repeating steps.

 

We'll be on the lookout for your answer.

LyubkaModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.

It’s broken for me after updating to the latest version on iOS (8.8.43.436)


Not had any problems before

 

Ive tried removing and reading to my screen, made no difference 

 

Happy to help debug if I can

 

Fixed on my iPad in the latest version (8.8.44.458) but still broken on my iPhone on the same version

Not sure if anyone at Spotify even monitors these forums feel free to reach out if I can help (I'm an experienced iOS dev)

Hi there @yeltzland,

 

Thanks for the post.

 

Sorry to hear that the widget on your iPhone still gets black. 

 

In regards to your first question, yes these forums get regularly checked by Spotify developers and user data and feedback is being passed on to the right folks who're working on new features or fixing issues with the app.

 

About the widget - can you try restarting your phone and see if the widget loads as expected afterwards? If it still becomes black, does it happen straight away when you play something, or after some time.

 

Keep us posted on how you get on.

AlexModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Turning my phone off and on again did actually fix it - thanks!

Have never seen a widget do that after an update before, but looks like it's fixed now (will update the thread if it fails again)

 

Cheers
John

I am still dealing with a broken widget in a stack.  Tried removing and readding and rebooting the phone.  No change.

 

Iphone se3 on 16.5.1

Plan: Premium

Country: USA

Device: iPhone 13

Operating System: iOS 16.5.1

 

The Spotify Widget is Blank. Clicking on it still leads to the app

 

 

Screenshot 2023-07-07 at 4.22.24 PM.png
IMG_2118.PNG
IMG_2117.PNG

hi. my spotify widget is also went black a couple days now. but it only happened on my ipad. on my iphone it works perfectly fine. i have removed the widget and it is still the same. havent uninstall nor restart my device as not sure if it is necessary. let me know if it is as i will try it.

Suggested posts