Announcements

Help Wizard

Step 1

NEXT STEP

App crashes at startup (tried every fix mentioned online)

App crashes at startup (tried every fix mentioned online)

Plan

Premium

Country

United States

Device

Samsung Galaxy S8

Operating System

Oreo 8.0.0

 

My Question or Issue

Hi all! Soooooooo, I haven't been able to use my Spotify app on my phone at all. At. All. For almost two weeks at this point. Here's the deal: One day, I'm using the app just fine. The next day, when I tap to open it, it opens for a split second, then immediately exits back to my home screen. No error message. It just exits. I don't even have a chance to tap on anything in the app.

 

I've tried every fix that's ever been listed online anywhere: I've cleared the cache, cleared the data, uninstalled, rebooted, gone through every single file in my phone to make sure that there aren't any bits left over, reinstalled, checked for viruses, made sure the app isn't being affected by either power-saving mode or data-saving mode, signed off of any connected devices, prayed to several deities.... Nothing helps. I don't use an SD card, so I can't really reformat anything.

 

The farthest I get is the sign-in screen if I've done a reinstall or a data/cache clear. As soon as I try to sign in by any means, it says it's signing in, gives the blank gray screen for a second, and exits.

 

Oddly enough, the only way the app ever stays open is if I'm in airplane mode. And even then, I can't access any of my downloaded songs or playlists. If I open the app in airplane mode and then turn airplane mode off, the app crashes.

 

My desktop app works just fine, so I know it isn't an issue with my account. I drive Uber, and as all of my Uber playlists are through Spotify, it's a REAL bummer that I can't use it. Any and all help would be greatly appreciated!

Reply
22 Replies

Same here with an iphone 6 latest ios applicable to te phone and latest updated spotify app. Ive tried everything!!! 

Ok ok ok just tried something and it worked for me...

1- go to airplane mode and turn it on

2- launch app and agree to it to being offline

3- go into account and log yourself off the app

4- now disable airplane mode

5- launch the app again and youll be asked to sign in again

6- sign in with your email and pw

7- once successful try to close the app the  launch again. If it works try to swipe to close the app completely and launch again and see if it works fine after that.

 

hope this fix works for you

This worked for me, thank you.

Suggested posts