Announcements

App stopping when I press specific button

Reply

App stopping when I press specific button

Visitor

Plan

Premium

Country

 

Device

Ulefone armour 6e

Operating System

Android

 

My Question or Issue

Hi. I've recently got a new phone (ulefone armour 6e) and my Spotify worked fine for a week or so but then when I tried to click on the top left corner of the songs it just blacks out and I need to reopen the app. I've tried reinstalling the app already. Any ideas for solving this conundrum? I've attached a screen recording of the issue.

6 Replies

Re: App stopping when I press specific button

Community Legend

Hey @Elad445 ,

 

Thanks for reaching out.

 

Let's do a clean reinstall first. Before that, disconnect all devices from your account here. 

 

Then follow these steps:

 

  1. Go to Settings on your phone.
  2. Select "Apps".
  3. Tap "Spotify" in the app list.
  4. Tap on "Storage> Clear Data" for a clean reinstallation.
  5. Tap Uninstall.
  6. Open Google Play and install the Spotify Music app.

 

There is something else you could do if that does not help. Go to:

 

  1. Mobile Settings> Apps> Spotify> Permissions. Allow everything you see there.
  2. Mobile settings> Apps> Spotify> Battery> Optimize battery usage> select top All (not optimized for apps)> Spotify> disable.
  3. Restart the phone.

Keep us posted!

PetyaModerator
 
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 

Re: App stopping when I press specific button

Newbie
This recommendation above doesn't work for me (ulefone Armor 6, Android 9), I been contacted the support team via Facebook Messenger but not response yet, any other work around or fix?
thanks

Re: App stopping when I press specific button

Visitor
If I open the playing song and tap the top right (not sure if OPmeant to say right instead of left) where the three dots are, the app freezes.

Re-installing and allowing background etc. usage didn't help me either. Ulefone Armor 6E and Android 9 here.

Re: App stopping when I press specific button

Visitor

I had the same problem, but found a fix. It seems that the problem is related to the Ulefone Armor 6e Android rom, and is not related to the Spotify App.

Unfortunately you need to flash the newest Android patch manually. I'm not sure why Ulefone does not distribute the newest Android rom, or hopefully it will be published later this year. The newest Android rom from Ulefone is from the 1st July 2020. As I say, not sure why it is not yet published over the air. I also did not receive it over the air. I flashed it manually to my Armor 6e and now the Spotify App works as expected.

 

Use at your own risk! Manually flashing can damage or brick your device unusable!

But if you decide to flash your device manually, you will find the necessary information here: https://forum.xda-developers.com/android/general/main-thread-ulefone-armor-6-stock-root-t3950516

Re: App stopping when I press specific button

Moderator
Moderator

Hey folks,

 

Thanks for searching for the answer you need here!

 

If you're app crashes when opening the three dots menu even after performing the clean reinstall and settings changes that @Petya suggested, it's possible that it's a case of this Ongoing issue. We recommend that you leave your +VOTE in the thread and subscribe to it, if you haven't already. We'll inform on any updates on the matter there, as soon as there are any.

@alfonso_g and @Elad445 note that @Stier1291 has found a fix for this for Ulefones, where the problem seems to have a different root cause. Keep in mind that the solution he posted might damage your device and you should use it at your own risk.

 

Hope you find this useful. Keep us posted if you have any questions.

MihailModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“Music is a language that doesn’t speak in particular words. It speaks in emotions, and if it’s in the bones, it’s in the bones.” - Keith Richards

Re: App stopping when I press specific button

Casual Listener
I've had an armor 6e for 2 years and had exactly the same experience as you. I've toyed with the idea with flashing the phone but wasn't optimistic it would help.
I'm grateful for your posting, your solution, Stier-san, thank you and have a great 2021!
And I can finally forgive Spotify for not giving the issue ask this time; peace.
SUGGESTED POSTS