Announcements

Help Wizard

Step 1

NEXT STEP

Change the storage to SDCard is not working

Solved!

Change the storage to SDCard is not working

Hello guys, i just signed the spotify premium (about two or three days).

when i try to sync my lists to listen in off-line mode the songs are downloaded in the internal storage.

 

I look for solutions in any foruns i know, but the i can't  fix that problem ... 

i try thats alternatives:

 

A) menu>setings>clear data and cache>relog

 

in this solution, the app keep storing the dates in internal storage, it is that i own a SDcard with 8GB free ... 

 

B) Download a lasted version of app, change the type of storage and update the app in PlayStore.

in this solucion, i could change the type of storage, but, when i try to update the app, don't exist option to update then, just saiyng to donwload the new version ... (I think that this problem happens because the older version is so many older)

I fonded this solucion in a topic created in 2012 ... 

PLEASE, i need help to make this work !!! 

(And i'm sorry for the english, i'm a brazilian guy and not very good whith this language !! )

Thanks a lot ! 

Reply

Accepted Solutions
Marked as solution

Please try clean reinstall

Go to System Settings
- Go to "Apps"
- Find Spotify there
- On Spotify's page, first, tap "Force Close"
- Then tap "Clear cache" if it's not greyed out.
- Then tap "Unninstall" and remove the app.
- After uninnstalling, power off your device.
- If you can, remove the battery now. Power back on.
- Using a file manager on your phone or with your USB cable and your computer, go to Internal Storage > Android > Data and delete a folder called com.spotify.mobile.android.ui
- Reinstall Spotify from Google Play
If my post helped you to fix your problem, please press "Accept as Solution" button.

View solution in original post

Marked as solution

Some additional detail: I'm running Spotify version 2.8.0.1081 on a Verizon Samsung Galaxy S5 runnning Lollipop 5.0.

 

I've learned that since Android went to KitKat 4.4.x, they have restricted how apps can communicate with the SD card for security reasons. Has Spotify revised its app to address this? I noticed in the permissions that it does not specify being able to read/write tot he SD card.

View solution in original post

11 Replies
Marked as solution

Please try clean reinstall

Go to System Settings
- Go to "Apps"
- Find Spotify there
- On Spotify's page, first, tap "Force Close"
- Then tap "Clear cache" if it's not greyed out.
- Then tap "Unninstall" and remove the app.
- After uninnstalling, power off your device.
- If you can, remove the battery now. Power back on.
- Using a file manager on your phone or with your USB cable and your computer, go to Internal Storage > Android > Data and delete a folder called com.spotify.mobile.android.ui
- Reinstall Spotify from Google Play
If my post helped you to fix your problem, please press "Accept as Solution" button.

I am having the same issue. I tried the solution outlned by atom 1989, but could not find the ui file called com.spotify.mobile.android.ui. I looked in both the internal storage and the SD card. I did find the Andoid folder, but that ui file was not present.

 

So, I reinstalled Spotify, but there is still no option to specify storage location in the settings menu.

Hey @gtshin could you find  \android\data\com.spotify.music folder and delete it?

If my post helped you to fix your problem, please press "Accept as Solution" button.

As I mentioned, I could not find the ui file called com.spotify.mobile.android.ui. I looked in both the internal storage and the SD card. I did find the Android folder, but that ui file was not present.

In my latest post i mentioned other folder.

\android\data\com.spotify.music
If my post helped you to fix your problem, please press "Accept as Solution" button.

Nope. Just went through it all again.

 

Just to be sure, I went into internal storage to see if I could find that folder, and I did. Then I went through all the steps of force closing, emptying cache, deleting data, powering down, removing battery, powering back up.

 

Went and looked for that folder and it was not there. Reinstalled Spotify, and there is still no option for selecting storage location.  Am I looking in the right place for it? I'm assuming it's under Settings, but all I see with regards to Downloading is quality levels.

Spotify should automatically sync offline tracks to sd cards. There is currently no option to choose.
If my post helped you to fix your problem, please press "Accept as Solution" button.
Marked as solution

Some additional detail: I'm running Spotify version 2.8.0.1081 on a Verizon Samsung Galaxy S5 runnning Lollipop 5.0.

 

I've learned that since Android went to KitKat 4.4.x, they have restricted how apps can communicate with the SD card for security reasons. Has Spotify revised its app to address this? I noticed in the permissions that it does not specify being able to read/write tot he SD card.

Well, ok, I'll give that try, then, and see if it works.

AWESOME! this worked! I'm so glad to see this! The spotify folder is now on the SD card, NOT in internal storage. Yay!  I just got the phone this week and was worried sick that the whole KitKat SD card issue meant that I would be very limited in what I could store on my phone.

 

So, glad to see ths worked out. I hope the OP is following this closely enough to understand that you don't have to choose a storage location now. That Spotify stores offline files on the SD card automatically.

 

Thanks again!

You are welcome 🙂 Enjoy your music!
If my post helped you to fix your problem, please press "Accept as Solution" button.

Suggested posts