Announcements

Connect not working to AV Receiver, no devices on Windows or Web

Solved!

Connect not working to AV Receiver, no devices on Windows or Web

Plan: Premium Duo

Country: US

Devices:

- Google Pixel 4, Spotify App

- Dell XPS-15, Windows 10 20H2

- Marantz NR1711, latest firmware

- 2x Google Nest Minis

- Amazon Alexa device (not sure the name/model, it's a room mates)

 

My Question or Issue

There are different symptoms on different devices, but the short version is that I recently had my internet go down (thanks Spectrum) and when I got it back online (required a plan change on my internet, so new provisioning on the modem, but all hardware stayed exactly the same) all of my Spotify Connect setups were broken.

 

On my laptop (both web app and Windows 10 Store desktop app) none of my devices show up except my Android phone.

 

On my phone, all of the devices show up, and I can play Spotify through all of them except for the Marantz AV receiver. 

 

Everything was working fine yesterday, the biggest thing that changed was that I was not able to access the internet on the Wi-Fi for ~12 hours while I was dealing with Spectrum. 

 

Here are the troubleshooting steps I've tried (none of them worked, and none of them changed any of the symptoms)

 

Android Phone:

- Clear cache

- Select 'local devices only'

- Uninstall/reinstall the app

 

Marantz Receiver:

- Changed from Wi-Fi to Wired

- Changed back to Wi-Fi and manually set a static IP address

 

PC: 

- Tried Web App & Desktop

- Cleared the cache on the desktop app

 

I'm at a loss for what to try next... Any suggestions? 

Reply

Accepted Solutions
Marked as solution

Thanks for the suggestions. I'll try and get my Windows 10 Desktop Player to talk to the Marantz receiver, so those will be the two devices I start on. Here's what I did:

1) Logged out everywhere, removed access to all 3rd party apps (Marantz HEOS and Google were listed)

2) Logged back in to web (didn't go to player) just so I could start typing this response out

3) Uninstalled the Windows 10 Desktop player

4) Performed a Factory Reset on the receiver, went through setup and connected it to the same network that my laptop is on via ethernet

5) Reinstalled the Windows 10 Desktop app from the Microsoft Store

6) Launched the Desktop App & logged into Spotify

7) Using Spotify Connect, I was able to connect to the receiver and start streaming, as expected!

 

I think it was the factory reset on the receiver that resolved it. I tried the 'Log out everywhere' and 'clear cache' suggestions before with no luck. The factory reset seems to have done it. 

Thanks for the suggestions, hopefully this can help someone else with a similar problem sometime in the future!

View solution in original post

4 Replies

A couple more things... 

 

I turned the Guest Wi-Fi on (none of the devices have ever connected to it before), connected both the Marantz AV Receiver and my phone to the new network, and am seeing the same symptoms. The guest network is configured to only run on the 2.4 GHz band. 

 

I then connected my PC to the guest network, and still could not see the Marantz receiver in devices.

Hey @nathan-j-murphy,


Thanks for the post! We'll do our best to help out.

 

Best thing you can try is to Log out Everywhere. After that clear the Spotify cache on all your devices. You can run a clean reinstall following this device specific guide.

 

After that, try connecting them one by one to the network and Spotify Connect to see where the connectivity issue will arise first.

 

It's also worth chaining the WiFi channel on your router. We'd recommend toggling between 1, 6 and 11. Especially when you have multiple devices on the same network.

 

Keep us posted on how you get on.

 

 

AlexModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!
Marked as solution

Thanks for the suggestions. I'll try and get my Windows 10 Desktop Player to talk to the Marantz receiver, so those will be the two devices I start on. Here's what I did:

1) Logged out everywhere, removed access to all 3rd party apps (Marantz HEOS and Google were listed)

2) Logged back in to web (didn't go to player) just so I could start typing this response out

3) Uninstalled the Windows 10 Desktop player

4) Performed a Factory Reset on the receiver, went through setup and connected it to the same network that my laptop is on via ethernet

5) Reinstalled the Windows 10 Desktop app from the Microsoft Store

6) Launched the Desktop App & logged into Spotify

7) Using Spotify Connect, I was able to connect to the receiver and start streaming, as expected!

 

I think it was the factory reset on the receiver that resolved it. I tried the 'Log out everywhere' and 'clear cache' suggestions before with no luck. The factory reset seems to have done it. 

Thanks for the suggestions, hopefully this can help someone else with a similar problem sometime in the future!

Hey @nathan-j-murphy,

 

Thanks for keeping us posted.

 

We're happy to hear that the issue got resolved for you and appreciate the detailed list of troubleshooting steps you went through! These could indeed be really helpful for other users on the Community facing similar issues.

 

If anything else comes up, we'll be happy to help out.

 

Cheers!

Mihail Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Suggested posts