Disable notifications for Spotify Connect when not in foreground

Reply

Disable notifications for Spotify Connect when not in foreground

lxgr
Newbie

Hello,

 

is there any way to prevent Spotify from synchronizing the currently played track to all my devices when the app is not opened?

 

Since today, as soon as I push play on one of my devices, Spotify will show a persistent notification in the Android notification bar on all of the other devices.

 

This is very annoying - being able to control another device remotely is a nice feature, but Push notifications, on every track change, without an option to disable that behavior, are really too much. I don't even want to think about the impact on battery life...

6 Replies

Daniel
Community Legend

You can disable notifications from within Android.

 

On the devices you do not want to see notifications, go to Settings - Apps - then select Spotify from the list.. Now uncheck the box which says 'Show Notifications'.

 

You can also get to this if a notification is present by long-pressing the notification, then pressing 'App Info'.

 

I wouldn't worry about your battery life, the synchronisation really does not use much battery. If you are rooted there are options such as Greenifying Spotify if you are really worried.


Please use the search feature before posting a problem/bug/idea.
What's a Spotify Rock Star, and how do I become one?
     Using Spotify Since March 10th 2009
     Twitter: @mechanimal82

Android Troubleshooting:
[COMPLETE GUIDE] How to fix most Android issues
Spotify Android Version History

JeppeTh
Regular
Agree, very annoying.
Disabling notifications isn't a good solution since that disables all spotify notifications permanently...

Peter__
Community Legend
It appears to stop working on my device after some time of not looking at Spotify - but dunno if that is a bug or not!

Peter
Spotify Community Mentor and Troubleshooter

Spotify Last.FM Twitter LinkedIn Meet Peter Rock Star Jam 2014


If this post was helpful, please add kudos below!

thowit
Newbie
Agree.
When playing music on my Mac I don't want to see notifications popping up on my phone.

I'd appreciate an option to disable this.

What's weird is that I dismiss the notifications like a hundred times, and at *some time* they actually stop popping up, but it's kind of random.

Please fix!

user-removed
Not applicable

I can't believe this hasn't been fixed yet, it's a trivial bug (or bad design choice) that would be an easy win for the dev team..

oilfighter
Casual Listener

Found this thread looking for the same answer. There should be an option to disable this!

SUGGESTED POSTS