Announcements

Help Wizard

Step 1

NEXT STEP

My autoplay isn't working, clean reinstall not working.

My autoplay isn't working, clean reinstall not working.

My autoplay isn't working I have done all the support tells me to do and yet it is still not working. Even a clean reinstall is not bring it back to function properly.
Reply
36 Replies

  1. None of the below information is required. However, the more you provide the easier it will be for us to try and help.

Plan

Free/Premium

Country

India

Device

One plus Nord ce 2 lite

Operating System

Android 10+

My Question or Issue

Autoplay isn't working, I tried it from 2 devices it doesn't work, when I play a playlist or add some songs to queue there's no problem but autoplay doesn't work at all and I am sure there's some problem with my account because when I tried it from another account it was working properly 

Hey @user-removed, thanks for reaching out to the Community!

Thank you for trying those steps. The last thing we could check is if Autoplay is on. You can check by following these steps

If it's enabled and you're still having issues, I'd recommend getting in touch with Customer Support. They'll take a look and do their best to help.

Have a nice day!

Billy-JSpotify Star
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

Hey @JayIsListening,

 

Thanks for reaching out here in the Community!

 

Could you try to log out > restart your phone > log back in to see if that makes any difference for you?

  
It's also a good idea to remove any apps or services that Spotify may be connected with or affected by (like battery optimization software running on your device). Make sure your OS is up-to-date as well.

 

In case the issue persists, would you mind asking a friend or a family member to log in on your mobile app and to see if they'll experience the same? 
 

Hope this helps. Let us know how you get on.

LyubkaModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.

I have done all you recommended. And the issue still persists.

Hey @JayIsListening,

 

Thanks for getting back to us and for the troubleshooting you've tried so far. 

 

In order for us to investigate this further, we'd need the Spotify version you're currently running. We can then relay the information to our tech team. 


Any additional details (such as device's make, model and OS) will be very helpful to our investigation as well. Sending us a quick video of the issue like would come in handy. You can attach it to your next response by using the Insert Video option in the post editor. If the attachment is too big - we'd suggest that you upload it to Google Drive and share the link with us (make sure the video has the permissions for anyone to see it).

 

Please make sure to include any relevant information as this way it'll be easier for our teams to understand the root cause of this.


We'll be on the look for your reply.

LyubkaModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.

Version 8.8.58.473

Samsung galaxy M11

Andriod 12

Hey @JayIsListening,

 

Thanks for keeping in touch and for providing the requested details.

 

Could you please let us know more specifics about the issue - without video we couldn't completely understand what's happening on your end. What about the autoplay feature is not working? In addition, we'd like to know what you were listening to - are you experiencing this on playlists created by Spotify or on the ones created by you? 

Lastly, would you mind sharing with us if you have other playback options enabled - like shuffle/repeat?

 

We'll be keeping an eye out for your response 🙂

LyubkaModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.


@JayIsListening wrote:
My autoplay isn't working I have done all the support tells me to do and yet it is still not working. Even a clean reinstall is not bring it back to function properly.


I have an update.

Autoplay works on an iPhone I used to test. But not on my phone.

And also the autoplay doesn't work on my phone even if shuffle/repeat is active or not.

Hey @JayIsListening and @user-removed,

 

Could you try logging in to your accounts on another Android device (a friend's or a relative's would do) to see if Autoplay works there? This would greatly help us narrow down the cause of the issue.

 

Could you also check if Autoplay works with playlists, albums or songs from Search?

 

We'll be on the lookout for your replies.

 

Cheers!

YordanModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a "Like".
Are you new to the Community? Take a moment to introduce yourself!

I logged in on my friends andriod and it worked. 

Thanks for confirming @JayIsListening!

 

We've forwarded this to the attention of our tech folks who'll investigate further. We'll keep you folks posted here as soon as we have any updates.

 

The Community is always here if something else comes up in the meantime.

YordanModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a "Like".
Are you new to the Community? Take a moment to introduce yourself!

Plan

Premium

Country

India

Device

Realme Narzo 50 Pro 5G

Operating System

Android 13

 

My Question or Issue

Autoplay isn't working. Even if autoplay is turned on whenever a song finishes playing then it just stops playing instead of playing some suggested songs.

 

Plan

Premium

Country

UK

Device

Samsung S6 Lite

Operating System

Android 11

My Question or Issue

Autoplay always remains on, even if I disable it in settings.

 

Plan

Premium

Country

Uruguay

Device

Samsung Galaxy S23 Ultra

Operating System

Android 13, OneUI 5.1

 

My Question or Issue

I'm having problems with my mobile phone on Spotify, the Autoplay function is not working. I alreay tried a fresh install, deleting cache, turning on-off the setting. Although the problem seems to only happen on my phone, the windows pc version of the app works just fine.

Update:

I fixed the problem by deleting the cache directly from the OS app drawer instead of doing it on the app itself

Hey everyone,

 

Our tech folks have made some changes backstage, so Autoplay should now activate when the last song in the queue finishes playing.  Could you check if the issue is fixed on your end?

 

We'll be on the lookout for your replies.

YordanModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a "Like".
Are you new to the Community? Take a moment to introduce yourself!

Songs are not playing continuously they stop after one song

For me, I can only turn it on/off on my desktop software. If I try to toggle the option on my Android phone, nothing happens.

Thanks for the reply @Wimands.

 

Could you try logging out and signing back in to your account to see if that helps? In case the issue persists, please share the following info so I can forward it to the team investigating this:

Cheers!

YordanModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a "Like".
Are you new to the Community? Take a moment to introduce yourself!

Suggested posts