Previous track button stops working randomly


Previous track button stops working randomly



Premium (Student)





Moto One Power

Operating System

Android Pie (running the latest update)


I cannot go to the previous track using media control buttons on neither my Boult Audio Tru5ive nor my  Sennheiser CX-275s. I am able to play/pause and skip ahead just fine, it's just the previous track button that doesn't work.


Sometimes, it would start working randomly and keep on working until a few days, then stop working again. I bought Premium (student discount) thinking that it'll fix the issue and sure enough, the controls worked fine up until yesterday when I started facing the same problem again.


Since then they have been working/ not working randomly. I've tried doing a clean reinstall as well. Nothing seems to work. Sometimes force stopping the app or reinstalling temporarily fixes the issue.


I also noted that I wasn't able to toggle the shuffle and repeat buttons. Again, they start working and stop randomly.

1 Reply

Re: Previous track button stops working randomly

Rock Star 16
Rock Star 16

Hi there!

I know it sounds simple, but it's often overlooked. Could you try restarting your device? If that doesn't help, try a clean reinstall of the app. Just follow these steps.


If the issue persists try using Sign Out Everywhere and Remove Offline devices options from your Spotify account.


Hope it helps 🙂

LoxerRock Star 16
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.