Songs saved to library still using data

Songs saved to library still using data

I just wasted 15 minutes in chat help with a moron.


I'm a week or two into my trial, happy with it and intend to continue paying for it each month. Except for one thing.


To summarise the issue:


If I listen in online mode, playing only songs saved to my library already, the app does not play the saved versions, but instead continues to stream them, using approx 150mb/hour.


If I turn off wifi, or manually set the app to offline mode, then I can only play songs through headphones, I can't play them through my AVR using spotify connect.


Being in a country with terrible internet infrastructure (Australia), using 1 gig a day to listen to music while at home isn't ideal, causes me to bounce off my monthly data limit.


I want the app to continue to use my home wifi to play songs through my home stereo setup. But I want the app to play the saved songs from my library, not redownload them to stream each & every time. This should not be difficult. Yet apparently it is...


Any advice, or will I be uninstalling spotify once my trial ends?

3 Replies

Connect devices stream music direct from Spotify's servers and not from your mobile so they don't care whether you have downloaded music to your mobile or not.

When a song is "saved" in spotify, it is added to your library and is listed there. This is not the same as downloading it for listening offline. Once you download a playlist or album following these steps, you should be able to listen to the music on your mobile when it is offline, but not on your hardware device. The only way to do this would be to use a different way to stream from your mobile to your AVR such as bluetooth or airplay.

You have my sympathies on the poor "broadband" you guys have in Oz and, if the app won't do what you need, then trying another service is the only answer.

Bit scared to answer you now because I don't want to be labeled as a moron too. But well, I feel lucky todat so let me give it a try and tell you how I fixed it myself:


In your Spotify app go to Your Library -> Settings (top right)  -> Scroll down to "Download using cellular" and make sure it's disabled (if it's green it's enabled).


This fixed it for me. Let me know how it goes. Cheer.

By the way, another idea is:


Go to Android Settings ->Data Usage -> Click on your provide -> Scroll down and select Spotify -> Enable "Restrict Background Data".


This is on an Android 5.0 version, so you have to click around a bit to find it on your phone but I'm sure it's there somewhere.

Suggested posts