Spotify connect "Phone locked or spotify not in foreground", is there a workaround this?

Reply
Highlighted

Spotify connect "Phone locked or spotify not in foreground", is there a workaround this?

Zequez
Regular

Device

Macbook Pro with MacOS 10.13 / Samsung Galaxy S7 with Android Oreo

 

I connect my phone to my bluetooth speakers and while at home I play music through there, so I don't have to listen to all my computer sounds through the speakers.

 

The problem is that as soon as Spotify is no longer in the foreground in my phone, it greys out in the connect menu, and I can't see any information of what's playing or control the phone.

 

HOWEVER, the weird thing is, if I start playing music on my laptop, it stops in my phone, so it cannot be a technical limitation that's preventing the computer from controlling the phone, so why the **bleep** is it disabled?

4 Replies
Highlighted

Re: Spotify connect "Phone locked or spotify not in foreground", is there a workaround thi

Zequez
Regular

So, I restarted my phone and now it's working again. This means there is something very weird going on here, specially since Spotify was displaying that message, but now I CAN put spotify on the background or have the phone locked, and the connect feature still works. So why does that message even EXISTS?!

 

I have all the battery saving features with Spotify excluded, is there something I'm missing?

Highlighted

Re: Spotify connect "Phone locked or spotify not in foreground", is there a workaround thi

Zequez
Regular

Started happening again today in the morning. Restarted the phone, and it works. Still trying to figure out what the **bleep** causes this issue with Spotify that doesn't happen just after the phone restarts.

However, I noticed something. It works, and I can change and see what's playing. HOWEVER, as soon as I pause, it stops working and the phone greys out from the connect list.

Highlighted

Disable Android Doze for spotify

Cubiss
Newbie

Disabling Android Doze for Spotify app solved most of issues I've had.

On your Android O go to:

Settings -> Apps & Notifications -> Advanced -> Special app access -> Battery optimization -> [ If you see list of 'Not optimized' apps, switch it to 'All apps' ] -> Spotify -> Don't optimize -> DONE
This should help.
If you use data saver, you might want to allow Unrestricted data for Spotify too. This will allow Spotify to use data in background even when you have data saver turned on.

Settings -> Apps & Notifications -> Advanced -> Special app access -> Unrestricted data -> [ Enable Spotify ]

Highlighted

Re: Disable Android Doze for spotify

a7-t_5gr7tvcq
Newbie

Thanks for the advice, unfortunaetly this doesn't solve the problem for me. Once the phone is locked, the music will continue and I can even skip songs or fast forward from my PC. However, as soon as I pause a song, Spotify will lose connection and tell me that a cannot reconnect unless I wake up my phone and move the Spotify App into the foreground.

I have just looked through several threads on here and on reddit, all asking for similar advice. I am puzzled as to why Spotify seem to be unwilling to solve this. Can anyone explain?

SUGGESTED POSTS