Help Wizard

Step 1

NEXT STEP

Spotify won't play certain podcasts

Spotify won't play certain podcasts

Plan

Premium

Country

USA

Device

Google Pixel 4

Operating System

Android 11

 

My Question or Issue

Hi there, just this past Monday (March 15, 2021) Spotify suddenly won't play podcast episodes from two specific podcasts I listen to ("Stuff You Should Know" and "Pod Save America"), while other podcasts I listen to, like "ShortWave," play just normally, and music also plays normally.
When I select an episode from those two that aren't working, the play button changes to the pause button, but the progress bar doesn't move and no sounds are heard.
So far, I've tried restarting my phone, uninstalling then reinstalling Spotify app, and trying to play the non-working episodes on wifi/mobile data and nothing has worked.

I would just like to reiterate that other podcasts, as well as music, work just fine; for some reason it's just these two podcasts in particular that aren't working. Any help beyond what I've tried would be greatly appreciated. 
Another thing I just realized, it seems like this issue pertains to ANY podcast under the "iHeartRadio" or the "Crooked Media" names.

Reply
59 Replies

Hey @jerviper

 

Welcome to the Community and thanks for reaching out about this. 

 

You mentioned that you've already reinstalled the app, but would you mind going through the steps of a clean reinstall, as it's more thorough than a normal one?

 

On another note, could you let us know if this is only happening on your phone or on a different device as well?

 

Lastly, could you send us the Spotify URIs of the podcasts you mentioned? To get them, open the Spotify desktop app > click the three dots next to the content > Share > Copy Spotify URI.

 

We'll keep an eye out for your reply 🙂

EniModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“Music acts like a magic key, to which the most tightly closed heart opens.”– Maria von Trapp

Hi there Eni, thanks for your reply.

I tried the thorough "clean reinstall," but I still have the same issues on my Google Pixel. 

 

It appears this is only an issue on my Pixel phone, as I'm able to log in on my account and play those podcasts on other devices (I tried an IPad, my windows laptop, and my PS4). Additionally, I had someone else log in to their account on my Pixel phone and those same podcasts don't play.

 

Here is the URI for the podcasts that aren't working:

Stuff You Should Know - spotify:show:0ofXAdFIQQRsCYj9754UFx

Pod Save America - spotify:show:5JGorGvdwljJHTl6wpMXN3

Conan O'Brien Needs a Friend - spotify:show:3u26tlz7A3WyWRtXliX9a9

And there are probably others that don't work, but these are just the ones that I found so far. 

Hey @jerviper,

 

Thanks for getting back to us.

 

The fact that the podcasts play correctly on other devices with your account and that other accounts experience the same issue on your Pixel 4 indicates that the root cause of the problem lies with that specific device. Could you make sure that the app has all permissions activated and is excluded from any battery or storage optimization services? Sometimes these can interfere with the cache and connectivity. If there are any updates for your Android, you should also install them.

 

On another note, you mention that this started happening on the 15th - can remember if this started happening after installing an app or an update? The more info we can gather on the circumstances when this started , the quicker we'll be able to get to the bottom of this.

 

Keep us posted. We're looking forward to your reply.

 

Mihail Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Hi Mihail,

Spotify app has all permissions granted on my phone, and there aren't any battery or storage optimization things enabled for the app.

Additionally, there was an update for the Spotify app last week on the 15th (could have been the night of the 14th), which is when this issue started. I didn't download any other app in that time period, and Android is up to date. Perhaps with the next Spotify app update this will be resolved. I'm just very confused on why this affects only certain podcasts and no music at all. 

Hi @jerviper

 

Thanks for this info. 

 

It would be helpful if you could send over a screen recording where we can take a better look at this issue to investigate further. Just attach it to your next response to us by using the Insert Video option in the post editor and make sure to exclude any personal info from it. 

 

We'll keep an eye out for your reply. 

NovyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a "Like".
Are you new to the Community? Take a moment to introduce yourself!

A screen recording of what exactly? Just me pressing play on the podcast and it not playing?

Hi again @jerviper

 

Thanks for your reply. 

 

Having a video where we can see exactly what happens when you press play would help us take a deeper look into this and it would also be helpful to see if we can replicate the issue from our end. 

 

Keep us posted.

NovyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a "Like".
Are you new to the Community? Take a moment to introduce yourself!

Hi there Novy, I can take a screen recording, but this forum only allows files up to 5MB and even a very short screen recording is about 35MB. 

Hey @jerviper

 

Not to worry.

 

In case the file size is too big, you can send over a link to the video so we can see it. 

 

We'll be on the lookout!

NovyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a "Like".
Are you new to the Community? Take a moment to introduce yourself!

Here's a link to my video!

https://i.imgur.com/HjZJArq.mp4

It shows two podcast's episodes not playing.

Hi @jerviper

 

Thanks for this info!

 

We understand you've already tried performing the clean reinstall that we suggested. However, we'd like to ask you to try it one more time making sure to clear both the cache and the storage data.

 

If it definitely doesn't work, could you send over the exact Spotify version you're currently running so we can investigate further?

 

We'll keep an eye out for your reply.

NovyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a "Like".
Are you new to the Community? Take a moment to introduce yourself!

Hi Novy,

Yesterday there was an update for the Spotify app which I downloaded. I then decided to shut off my phone and keep it off for a few minutes (about 3-5 min), then turned it on and those podcasts started working again! Not exactly sure what happened, but I'm happy to report Spotify is working again.

Hey @jerviper

 

Thanks for keeping us in the loop.

 

We're glad to hear that everything is now working as it should. 

 

If anything else comes up, you know where to find us.

 

Have a good one 🙂

NovyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a "Like".
Are you new to the Community? Take a moment to introduce yourself!

I have this issue as well. Have tried all the steps in this thread and the problem persists. Only difference is I am using a Pixel 3A. 

Hi there @chriskillco,

 

Thanks for reaching out to the Community!

 

To confirm, have you tried logging out, restarting your device, and logging back?

 

If the issue persists, can you let us know if it's happening with the same podcasts or different ones? Is it happening in any other devices?

 

Keep us posted.

CarlosEModerator
 
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 

Hi, I have the same issue on my Pixel 3a. I tried logging out and restarting, which did not help. Neither did a clean re-install. Logging in with someone elses account on my phone also gives the same result. The podcasts I noticed it with are "Fest und Flauschig" and "Twenty Thousand Hertz".

 

My spotify version is 8.6.78.266 and my phone runs Android 12, however the problem already persisted under Android 11.

Hi @Teph12,

 

Thank you for posting on this thread!

 

Since two different accounts are having the same issue on your Pixel phone, could you access your account using another device and check if you're able to play the podcasts? 

 

Also, if you're a Premium user, are you able to download the podcasts? 

 

Lastly, do you get any error messages when trying to play them? 

 

Keep us posted.

MafeGModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Hi,

I am able to play the podcasts both on my PC as well as on someone elses phone (iOS and Android) from my account.

Downloading the podcast does not work. It does not show an error message, instead it seemingly starts downloading, but remains at 0% progress. The same happens when playing the podcast, it just stays at 0:00 (see the attached screenshot).

Screenshot_20211118-121528.png

I believe I just found the solution: I was connected to a system wide adblocker. After disabling the adblocker, I can now play and download the podcasts as usual.

Suggested posts