Announcements

Yamaha WXC-50 & Spotify Connect problem. Finds device but cannot connect

Solved!

Yamaha WXC-50 & Spotify Connect problem. Finds device but cannot connect

Hi,

 

I'm really struggling to set up my new Yamaha WXC-50 with Spotify Connect. Everything works fine until I go to Spotify devices and click on the "Room1" (that's the name for my Yamaha). It says "Connecting..." for some time and then the selection goes back to previously selected device... I've tried this with multiple different devices (android, iOS, Windows10) but always the same thing. Yamaha can be found from devices but cannot connect. I even tried two different Yamaha's and another wlan router but no difference. Yamaha works in other wireless network so it must be the combination of my network and the Yamaha. Other devices in my network work just fine with Spotify Connect e.g. Alexa Dot, Sonos Connect etc... I found some earlier posts about Yamaha receivers not working with Spotify Connect but I think that was a different problem since in those cases the device didn't show up at all in Spotify.

 

 

 

 

Reply

Accepted Solutions
Marked as solution

Hi,

For me the problem was my Spotify account. After trying everything else I tried my friends Spotify account and the problem dissapeared! I immediately created a new account for myself and now everything works with Yamaha exactly like supposed to. Spotify didn’t know what the problem was but they said sometimes there can be technical problems linked to accounts...

View solution in original post

5 Replies

Hi Dude,

 

I have the same Yamaha WXC-50 (buy it two weeks ago) and the same issues, but I can connect using Yamaha Music Cast, then I call Spotfy via Music Cast. Works fine for some minutes, maybe some hours, but always connection stop working and i need to configure again. I don't have problems with deezer ou net radio, just spotfy.

 

Waiting for some words from Spotfy team.

Marked as solution

Hi,

For me the problem was my Spotify account. After trying everything else I tried my friends Spotify account and the problem dissapeared! I immediately created a new account for myself and now everything works with Yamaha exactly like supposed to. Spotify didn’t know what the problem was but they said sometimes there can be technical problems linked to accounts...

Same issue here. Cannot play spotify through WCX-50. Netradios are working well. Spotify does not show wcx-50 as available players.

Hope this can be solved quickly. 

 

I also have connectiong problems, at first try musiccast app cannot find wcx, but manually conection to existing sytestem fixes the connection problem. I Think this is related to above mentioned problem.

 

I tried different account, but without any success.

Some update.

 

I change my WXC-50 connection from wifi to directed attached modem via ethernet cable. Since then, I didn't notice any more problems with Spotify losing connection.

 

 

 
I strongly advise. 🙂

Thanks, this solved the problem ! 

But wireless connection still has problem.......

Suggested posts