Help Wizard

Step 1


"Get the Best Experience on Android 12..." Pop Up

"Get the Best Experience on Android 12..." Pop Up






Galaxy Note 20 Ultra

Operating System

Android 12


My Question or Issue

I keep getting a pop up that says "Get the best Spotify experience on Android 12...Allow Bluetooth". I don't necessarily see a reason to allow bluetooth since everything is working fine for me. The problem is, I click "maybe later" but it comes up every single time i open the app even if it was just minimized for a second. How do I disable this thing?

Top Answer

I went into settings on my device and it was on 'do not allow'. I toggled it to 'allow' then back to 'do not allow' and that seems to have fixed this pop up constantly appearing. The app has closed itself when I did it because my music stopped playing when I did. So I think of people followed your directions and then reset the app, it would probably fix this. Also maybe do it while not connected to any Bluetooth devices. That might be confusing the app.

94 Replies

A recent update to the spotify app keeps asking me to enable permissions to control bluetooth devices on Android 12.

There should no reason the app keeps asking me to enable it over and over again. I said no, I do not want to enable it. please fix the app to stop asking every time I launch it.

Amen to this. Turn off this fake warning that says Bluetooth won't work, and let us get rid of it. I don't want to grant permissions later, I want to deny the permission outright.


If it's not removed, I will very quickly find another music app.

Found this report while looking for fixes for the same issue.


I have premium account, in Canada, on a Galaxy Note 20 Ultra running Android 12.


Happens everytime I open the app, even if the app is already running in the background. Reappears no matter if I choose "Allow" or "Maybe Later"

I agree to a certain extent. Spotify should not need access to Bluetooth to work. The fact it asks repeatedly after I declined to give it permission is frustrating. Please fix.


Maybe it is just messaging issue in the fact that the nearby device option will not work for Bluetooth devices without the permission but the popular to not say that  The popup message makes you think you need Bluetooth enabled to use Spotify and it may not work with it.

Got the same problem on Samsung S22 Ultra

Same here, started a few days ago. Won't go away even though everything including Bluetooth is already on.

It's an awful update. I don't need Spotify telling me every time Bluetooth is off. Disable please.

I'll be looking for an older app version until this unhelpful "feature" is removed.

Same problem for me here on a Samsung Galaxy A52s from The Netherlands with Spotify premium. It does not matter what I choose it keeps popping up. 

Echo on pixel 6. Bluetooth is on and even if it wasn't I wouldn't want to enable it through Spotify.

Pixel 3a

Android 12

Android version

I have the exact same (annoying) experience. 

Same here. INCREDIBLY annoying. Literally any time it is minimized and opened. Eff no, stop it.

Fix this!


Hey everyone! 


Sorry to hear this is happening to you, we'll try to get to the bottom of it as quickly as possible.


Could you try allowing/not allowing this directly from your phone's settings? Here's how:

  1. On your phone, open the Settings app.
  2. Tap Apps.
  3. Tap the Spotify app.
  4. Tap Permissions > Nearby Devices.
  5. Choose either to Allow or Don't allow.

If you've done that and you still get the pop up, could you let us know your OS and Spotify versions, so that we'd be able to take a closer look?





Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

I toggled "Nearby Devices" a few times but still get the popup every time. Clicking "Allow Bluetooth" on the popup doesn't appear do anything. I just reinstalled the app due to upgrading to premium to fix my greyed out options.


Spotify Version:

Android version: 12

Pixel 6

Yep. Thanks Spotify for fixing the ridiculous forced music sharing feature which tells you all the people who are also listening. A terrible idea which you have removed. Do the same for this please!

This indeed is so annoying. Even when Spotify is working in the background and you go back to it later, the pop up appears again. I am indeed meanwhile so annoyed to choose another music app. This just doesn't work for me when I pay for something.

This response is a joke, right? The OS is in the title of the problem. No your garbage response does not change the popup.






Galaxy S10e


My Question or Issue

How can I get this popup to stop showing every single time I open the app on my phone? I don't have any bluetooth compatible "nearby" devices. I don't even have bluetooth enabled on my phone. I don't want to enable it 'maybe later,' I do not want or need to enable it ever.


I have tried uninstalling and reinstalling the app, making sure it was up to date, restarting my phone, and all of the other basic recommendations.

Same issue here on Android 12, pixel 3a, Premium, US. Bluetooth is my primary listening mode.


Not sure what it's even asking for. Hopefully this is an easy "feature" to toggle off.

Suggested posts