Help Wizard

Step 1

NEXT STEP

FAQs

Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...

VIEW ALL

Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...

VIEW ALL

Can't launch clean install on Linux Mint 17

Can't launch clean install on Linux Mint 17

 I'm running a clean install of Linux Mint 17, obtained from the repository (http://repository.spotify.com). When attempting to launch Spotify I get the following error:

 

$ spotify
spotify: error while loading shared libraries: libudev.so.0: wrong ELF class: ELFCLASS64

 

Google didn't turn up much. I suspect I've stumbled onto a bug of some sort. The exact version from the repo was:

 

spotify-client (1:0.9.4.183.g644e24e.428-1)

 

Anybody have any ideas?

Reply
4 Replies

Hey @jfish,

 

 

 

Installing 32-bit libudev0 should fix the issue:

sudo apt-get install libudev0:i386

If this does not work, you can try the non-stable version. Link.

 

 

Thanks for the tip! I ran an apt-get update and then tried installing libudev0:i386, however I encountered the following error:

 

Package libudev0:i386 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'libudev0:i386' has no installation candidate

 

 

I then purged the repo version and noticed something interesting:

 

Package 'spotify-client' is not installed, so not removed. Did you mean 'spotify-client:i386'?

 

I'm on 64-bit architecture and a 64-bit version of Mint. Not sure why the ppa downloaded the i386 edition. Following your link I was able to download a 64-bit version of Spotify, and that launched successfully. While I'd prefer to install from the repos, if that's not possible, this is a good workaround, thanks!

Hey @jfish,

 

The only stable version of Spotify is the 32-bit one.

From the link above you can get your hands on the latest non-stable release of Spotify.

 

Because you are running 64-bit OS you already have 64-bit libudev0, and the package needs the 32-bit one. As we all know when it comes to libraries in Linux sometimes it's messy and you want to avoid messing with them as much as you can. 
That said, it's best to stick with the latest non-stable version 🙂

Switching to the 64-bit/unstable version manually (as the others suggested) did the trick for me. I'd like to add that you can simply install it using "sudo apt-get install spotify-client:amd64".

Suggested posts