Help Wizard

Step 1


Can't open Spotify on Arch Linux

Can't open Spotify on Arch Linux






Asus X571GT 

Operating System

Arch Linux


My Question or Issue

I haven't been able to open Spotify (the AUR version) for the last few hours from an app launcher. When I try to open it through the terminal, it prints the following message: "Error: second time provided was later than self".

2 Replies

Sadly Spotify is not supported on Linux, you'll have better luck looking elsewhere.  Since you are on Arch Linux, a million things could be wrong. From your error message I would assume something's wrong with your timezon, try setting it with timedatectl.  Are you using Xorg or Wayland? Have you tried launching it from an application launcher or just the terminal?

Had the same issue just now, I'm on manjaro.
Before spitting the error, it said for me: *Loading configuration file at "/etc/spotify-launcher.conf"*
And indeed the conf file had a problem with the timestamp, fixed it by creating a new file and copy pasting the previous files data into it.

Suggested posts