[Linux] [Debian] Spotify Client 1.0.15: No music hearable

Solved!
Reply

[Linux] [Debian] Spotify Client 1.0.15: No music hearable

Schnoogemetzger
Regular

Hi,

 

after upgrading from 1.0.14.124.g4dfabc5 [1] to 1.0.15.137.gbdf68615 [2] all seems fine, except a major problem, I don't hear a darn thing 😉

My songs are playing, but I can't hear the music. After downgrading to 1.0.14.124.g4dfabc5 I hear the music again.

I'm using your "testing" Debian repository [3] and my operating system is a Debian Testing.

If I start spotify from a terminal, I can't see a explicit error about a sound issue.

 

Can you please investigate?

 

 

[1]

$ spotify --version 

Spotify version 1.0.14.124.g4dfabc51, Coyright (c) 2015, Spotify Ltd

 

[2]

$ spotify --version
Spotify version 1.0.15.137.gbdf68615, Copyright (c) 2015, Spotify Ltd

 

[3] deb http://repository.spotify.com testing non-free

1 ACCEPTED SOLUTION

Accepted Solutions
Solution!

jooon
Spotify
Spotify

Can you try version 1.0.17 that was just released and see if it works. Pulseaudio is not a required dependency. This is just a case of bad programming and testing.

View solution in original post

26 Replies

Dreadlord
Community Legend

Hello @Schnoogemetzger,

 

Please note that the version you are using is non-stable.

However, it sounds like Spotify is using the wrong output channel ( common issue with Debian ).

 

You can play around with the sound manager and see on which channel Spotify is working. ( If there is no channel available Spotify will start skipping songs. )

If this solved your issue - Mark it as a solution!
Twitter | Website |
What's a Spotify Rock Star, and how do I become one?



Schnoogemetzger
Regular

Hi @

 

> Please note that the version you are using is non-stable.

Jepp, I know. But a problem is a problem and I'll be patient, because it is non-stable 😉

 

> However, it sounds like Spotify is using the wrong output channel ( common issue with Debian ).

I unmuted several channels, but no luck so far. Is there a config file to adjust the channel output? Or at least, can I see in the log file, which channel is used?

 

> ( If there is no channel available Spotify will start skipping songs. )

Ahh, after 30-40 sec. the song skips to the next one. So, it seems to me, spotify doesn't find the right channel.

Dreadlord
Community Legend

Hello @Schnoogemetzger,

 

I would suggest you to use PulseAudio as sound manager in Debian 🙂

If you still have issues with the sound, please give me the output of the following commands: 

 

 

lsof /dev/snd/*
fuser -v /dev/snd/*

 

 

If this solved your issue - Mark it as a solution!
Twitter | Website |
What's a Spotify Rock Star, and how do I become one?



Schnoogemetzger
Regular

>I would suggest you to use PulseAudio as sound manager in Debian 🙂

Hmm, I don't know. I'm considering. PulseAudio isn't a requirement, so far? I mean, you can only help further, if I use PulseAudio?

I will test spotify on another box.

In the meantime, my output from lsof and fuser about the sound devices:

Output without spotify running:
$ lsof /dev/snd/*
COMMAND     PID  USER   FD   TYPE DEVICE SIZE/OFF  NODE NAME
xfce4-vol 12190 <USER>  9u   CHR  116,2      0t0 17199 /dev/snd/controlC0

$ fuser -v /dev/snd/*
/dev/snd/controlC0:  <USER>     12190 F.... xfce4-volumed

With spotify 1.0.14:
$ lsof /dev/snd/*
COMMAND     PID  USER   FD   TYPE DEVICE SIZE/OFF  NODE NAME
xfce4-vol 12190 <USER>  9u   CHR  116,2  0t0 17199 /dev/snd/controlC0
spotify   30355 <USER>  mem  CHR  116,3      17489 /dev/snd/pcmC0D0p
spotify   30355 <USER>  96r  CHR  116,33 0t0   317 /dev/snd/timer
spotify   30355 <USER>  97u  CHR  116,3  0t0 17489 /dev/snd/pcmC0D0p
spotify   30355 <USER>  101u CHR  116,2  0t0 17199 /dev/snd/controlC0

$ fuser -v /dev/snd/*
/dev/snd/controlC0:  <USER>     12190 F.... xfce4-volumed
                     <USER>     30355 F.... spotify
/dev/snd/pcmC0D0p:   <USER>     30355 F...m spotify
/dev/snd/timer:      <USER>     30355 f.... spotify

With spotify 1.0.15:
$ lsof /dev/snd/*
COMMAND     PID  USER   FD   TYPE DEVICE SIZE/OFF  NODE NAME
xfce4-vol 12190 <USER>  9u   CHR  116,2  0t0 17199 /dev/snd/controlC0
spotify   31734 <USER>  mem  CHR  116,3      17489 /dev/snd/pcmC0D0p
spotify   31734 <USER>  96r  CHR  116,33 0t0   317 /dev/snd/timer
spotify   31734 <USER>  97u  CHR  116,3  0t0 17489 /dev/snd/pcmC0D0p
spotify   31734 <USER>  98u  CHR  116,2  0t0 17199 /dev/snd/controlC0

$ fuser -v /dev/snd/*
/dev/snd/controlC0:  <USER>     12190 F.... xfce4-volumed
                     <USER>     31734 F.... spotify
/dev/snd/pcmC0D0p:   <USER>     31734 F...m spotify
/dev/snd/timer:      <USER>     31734 f.... spotify

Dreadlord
Community Legend

Hey @Schnoogemetzger,

 

PulseAudio is not mandatory, I will be able to help you in either way.

Can you please let me know the output of the following line: 

 

 

 

aplay -l

 

 

If this solved your issue - Mark it as a solution!
Twitter | Website |
What's a Spotify Rock Star, and how do I become one?



anonimo
Casual Listener

No audio for me neither. Going back to 1.0.14 solved it. These command outputs are with 1.0.15 running and playing music.

 

$ lsof /dev/snd/*
COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME spotify 17173 myuser mem CHR 116,3 14531 /dev/snd/pcmC0D0p spotify 17173 myuser 98r CHR 116,33 0t0 10011 /dev/snd/timer spotify 17173 myuser 99u CHR 116,3 0t0 14531 /dev/snd/pcmC0D0p spotify 17173 myuser 100u CHR 116,2 0t0 14530 /dev/snd/controlC0
$ fuser -v /dev/snd/*
                     USER        PID ACCESS COMMAND
/dev/snd/controlC0:  myuser     17173 F.... spotify
/dev/snd/pcmC0D0p:   myuser     17173 F...m spotify
/dev/snd/timer:      myuser     17173 f.... spotify

 

 

$ aplay -l

**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC892 Analog [ALC892 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 1: ALC892 Digital [ALC892 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 8: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 9: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

momaku
Regular

Same problem with OpenSuSE Tumbleweed, the others multimedia applications work without problem, except 1.0.15.

 

 

I returned to 1.0.14 and it is working well.

 

Recydywa
Casual Listener

I'm on Ubuntu 15.10 and I have exactly the same problem.

 

Today was a new version of Spotify in updates but it diddn't resolve this bug.

 

$ spotify --version

Spotify version 1.0.16.104.g3b776c9e, Copyright (c) 2015, Spotify Ltd

 

Also there is one more user with this problem and he posted in this thread:

 

https://community.spotify.com/t5/Help-Desktop-Linux-Windows-Web/Pulse-Audio/td-p/1221343

deki
Casual Listener

Since 1.0.15 (and 1.0.16) audio is no longer working for me too (Debian, no Pulseaudio, kernel 4.2).

sintendo
Newbie

I have the same issue with 1.0.15 and 1.0.16 running on Gentoo (4.0.5 kernel) , XFCE, no pulseaudio. Going back to 1.0.14 fixes the problem.

sauronpk
Casual Listener

Same problem here

Xubuntu 14.04.3

No pulse audio

 

Please FIX IT!

r4mnes
Regular

I'm also hit by that same problem on Gentoo, with version 1.0.16.104.g3b776c9e. Like others, I'm using Alsa only.

 

I made sure to deactivate all my sound cards (with modprobe.d blacklist keyword) except the one I'm actually using, so Spotify couldn't choose the wrong one. Even with only one soundcard, it doesn't change anything.

 

Spotify output doesn't tell anything interesting except that it's using Alsa, as expected.

 

Also, I remember that in the past we were able to choose the output channel in the settings, and that's not the case anymore; why?

 

dvvo
Newbie

Same here, gentoo, alsa, kernel 3.x - now 4.0.5, version 1.0.14 was latest working.

 

diffin spotify --show-console  shows nothing important.

FuxSnow
Newbie

I have the same issue. I have spotify-1.0.16.104 installed, I'm running Arch Linux with kernel 4.2.3, and no sound with ALSA. Using Pulse Audio works just fine, I'd like to know if since latest versions Pulse Audio has become a required dependency. Thanks

nggngg
Casual Listener

I have the same issue on Gentoo AMD64 with kernel 3.18.16 with no pulseaudio.

Spotify 1.0.15 and 1.0.16 have no sound, 1.0.14 works fine.

Based on ltrace outputs, it seems that spotify starts a new thread that actually plays the music, but it exits with the new version.

 

aplay -l

**** List of PLAYBACK Hardware Devices ****
card 0: HDMI [HDA Intel HDMI], device 3: ID 2807 Digital [ID 2807 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 0: ID 887 Analog [ID 887 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
cat /etc/asound.conf

pcm.!default {
        type plug
        slave.pcm "dmixer"
        ttable.0.0 4.0
        ttable.1.1 4.0
}

pcm.dmixer  {
        type dmix
        ipc_key 1024
        slave {
                pcm "hw:1,0"
                period_time 0
                period_size 1024
                buffer_size 4096
                rate 44100
        }
        bindings {
                0 0
                1 1
        }
}

ctl.!default {
        type hw
        card 1
}

ctl.dmixer {
        type hw
        card 1
}
# version 1.0.16
ltrace -f -e snd_pcm_\* -p 12092

[pid 12111] exe->snd_pcm_sw_params_sizeof(0xf1eb9580, 0xac44, 16, 2) = 136
[pid 12111] exe->snd_pcm_sw_params_sizeof(0xf1eb9580, 0xac44, 0, 2) = 136
[pid 12111] exe->snd_pcm_drop(0xf251d400, 2, 0, 2) = 0
[pid 12111] exe->snd_pcm_close(0xf251d400, 0x54a1, 0, 0) = 0
[pid 12111] exe->snd_pcm_open(0xf1eb95c0, 0x1433481, 0, 0) = 0
[pid 12111] exe->snd_pcm_set_params(0xf251d200, 10, 3, 2) = 0
[pid 12111] exe->snd_pcm_get_params(0xf251d200, 0xf1eb95f0, 0xf1eb95f8, 0) = 0
[pid 12111] exe->snd_pcm_sw_params_current(0xf251d200, 0x3448900, 0, 1024) = 0
[pid 12111] exe->snd_pcm_sw_params_set_start_threshold(0xf251d200, 0x3448900, 0x7fffffff, 1024) = 0
[pid 12111] exe->snd_pcm_sw_params_set_avail_min(0xf251d200, 0x3448900, 1024, 0) = 0
[pid 12111] exe->snd_pcm_sw_params(0xf251d200, 0x3448900, 1024, 0) = 0
[pid 12111] exe->snd_pcm_prepare(0xf251d200, 0x3448900, 0, 0) = 0
[pid 12111] exe->snd_pcm_nonblock(0xf251d200, 1, 0, 0) = 0
[pid 12121] +++ exited (status 0) +++

  

# version 1.0.14
 ltrace -f -e snd_pcm_\* -p 9889

[pid 9907] exe->snd_pcm_sw_params_sizeof(0x45189140, 0xac44, 16, 2)      = 136
[pid 9907] exe->snd_pcm_sw_params_sizeof(0x45189140, 0xac44, 0, 2)       = 136
[pid 9907] exe->snd_pcm_open(0x45189180, 0x13ced41, 0, 0)                = 0
[pid 9907] exe->snd_pcm_set_params(0x465ad800, 10, 3, 2)                 = 0
[pid 9907] exe->snd_pcm_get_params(0x465ad800, 0x451891b0, 0x451891b8, 0) = 0
[pid 9907] exe->snd_pcm_sw_params_current(0x465ad800, 0xa15f3c70, 0, 1024) = 0
[pid 9907] exe->snd_pcm_sw_params_set_start_threshold(0x465ad800, 0xa15f3c70, 0x7fffffff, 1024) = 0
[pid 9907] exe->snd_pcm_sw_params_set_avail_min(0x465ad800, 0xa15f3c70, 1024, 0) = 0
[pid 9907] exe->snd_pcm_sw_params(0x465ad800, 0xa15f3c70, 1024, 0)       = 0
[pid 9907] exe->snd_pcm_prepare(0x465ad800, 0xa15f3c70, 0, 0)            = 0
[pid 9907] exe->snd_pcm_nonblock(0x465ad800, 1, 0, 0)                    = 0
[pid 10275] exe->snd_pcm_state(0x465ad800, 0x136bab0, 0, 3)              = 2
[pid 10275] exe->snd_pcm_start(0x465ad800, 0, 2, 0)                      = 0
[pid 10275] exe->snd_pcm_wait(0x465ad800, 50, 0, 0x44d3b)                = 1
[pid 10275] exe->snd_pcm_avail(0x465ad800, 0, 1, 0)                      = 4096
[pid 10275] exe->snd_pcm_writei(0x465ad800, 0x46536000, 215, 0xfcb64b3c) = 215
[pid 10275] exe->snd_pcm_state(0x465ad800, 0, 0x45189158, 3)             = 3
[pid 10275] exe->snd_pcm_wait(0x465ad800, 50, 3, 0)                      = 1
[pid 10275] exe->snd_pcm_avail(0x465ad800, 0, 1, 0)                      = 4017
[pid 10275] exe->snd_pcm_writei(0x465ad800, 0x46536000, 2048, 0x14d63e8) = 2048

 

 

sauronpk
Casual Listener

fix please 😞

Poltiser
Music Fan

In Xubuntu 15.04 AMD64 (Kernel 4.23) with pulse audio - spotify testing works very well - with web and cache contents; what does not work is player of local mp3, wma itp. (which without any problem I can listen to using VLC player)...

Solution!

jooon
Spotify
Spotify

Can you try version 1.0.17 that was just released and see if it works. Pulseaudio is not a required dependency. This is just a case of bad programming and testing.

View solution in original post

sauronpk
Casual Listener
not working here with 1.0.17
SUGGESTED POSTS