Help Wizard

Step 1


Media Keys Don't Work

Media Keys Don't Work






(Desktop PC)

Operating System

Debian with Unstable Updates


My Question or Issue

 The Media Keys Play/Pause/Next/Previous on the keyboard don't work with the Spotify Application.


The Media Keys work with other applications in Linux such as Clementine and also work with the Spotify Application in Windows just fine. I would think it should be easy to make the media keys work just like they do in Clementine and other media applications in Linux.

90 Replies

Same problem here with version Did anyone find a solution?

I use the following workaround while the issue is not fixed:

chmod +x
sed -i 's/com.spotify.qt/org.mpris.MediaPlayer2.spotify/'
./ -n -s &

@sakinyu wrote:

Same problem here with version Did anyone find a solution?

Currently the only solution is to roll back to version

I have contacted Spotify support and can confirm that they are aware of the issue and this forum thread.


I'm hoping we have a fix for this soon!

thanks dersu! using spotify-notify I can use the latest spotify version and still have working media buttons!

This is a new feature that I would like to not vote for. 🙂 I upgraded spotify Monday(Yesterday) morning via apt. The media keys have worked for me without any issue until Monday after the upgrade. Here is the version I am running now:

root@nparry-laptop1:~# dpkg -l | grep spotify
ii spotify-client 1: amd64 Spotify streaming music client

I have this spotify repo setup on my box:

root@nparry-laptop1:~# grep -i 'spotify' /etc/apt/sources.list | grep -v '#'
deb stable non-free

I am running Ubuntu 16.04:

root@nparry-laptop1:~# lsb_release -d
Description:	Ubuntu 16.04.5 LTS

Let me know if there is anything else I can provide that would assist you.


Also, nice work with this spotify linux client in general. This is the only problem I have experienced with it since I discovered Spotify. So, thanks!


I also have this issue since the most recent upgrade to


Is there a way to flag this to the actual Spotify support/Linux team for resolution?

@poq wrote:

Is there a way to flag this to the actual Spotify support/Linux team for resolution?

Per @navnav Spotify support are reportedly aware of it.

2019 and it still doesn't work.

snap 2.36.3
snapd 2.36.3
series 16
ubuntu 16.04
kernel 4.4.0-141-generic

Spotify version, Copyright (c) 2018, Spotify Ltd

Spotify installed via apt-get though, as the spotify site instructions tells.

One more workmate has the same issue, which was expected since she has the same setup as me.

Another detail is that the media keys work with other applications.

Downgrading didn't work for me.

@MadMartian wrote:

Downgrading didn't work for me.

What version did you downgrade to?


I haven't had working media keys on Ubuntu 16.04.5 LTS since version

Media keys still not working in Spotify for me with the following:


Distributor ID: Ubuntu
Description: Ubuntu 16.04.5 LTS
Release: 16.04
Codename: xenial

Linux 4.4.0-141-generic #167-Ubuntu SMP Wed Dec 5 10:40:15 UTC 2018 x86_64 x86_64 GNU/Linux

spotify 30 stable spotify✓ -


Reverting to the snap below restores expected media key functions within Spotify.
spotify 21 stable spotify✓ - didn't work for me.

I also tried an earlier version that, I cannot remember which one specifically, but it was an early 2018 release.

The following probably only serves to add to the mystery at this point.


I have a laptop with built in media keys that is running Debian Stretch and is on spotify 30 stable. Unlike my Ubunut Xenial laptop, it is not encountering any problem with the media keys. (The media keys on the Xenial laptop are on a Logitch K750 keyboard and they are still working with snap version refernced in my prior posts.)

The new update 1: responds to media keys but incorrectly and is still unusable:

  • Stop - Pauses instead (play button should double as play/pause)
  • Prev Track - Previous track as expected
  • Play - Next track instead
  • Next Track - Does nothing

I upgraded to a newer version of the spotify-client this morning. Media keys still don't work. However, they do work as expected for RhythmBox. And, they did work(for several years with no issues) with the linux spotify client.

Here is the version I just upgraded too(via apt):

nick.parry@nparry-laptop1:~$ dpkg -l | grep spotify
ii  spotify-client                              1:                     amd64        Spotify streaming music client

Let me know if there is any other info that you need from me. Thanks.

I'm on Spotify (using snap candidate channel) on Ubuntu 16.04. Same problem: media keys don't work.

The problem for these bizzare key mappings was on my end, for some reason my key mappings were borked.  This did not affect other media players like RhythmBox, Amarok or Clementine, just Spotify.  In KDE, I corrected the mappings found under Global Keyboard Shortcuts / Media Controller and now Spotify is responding to media keys as expected.

Global Keyboard Shortcuts / Media ControllerGlobal Keyboard Shortcuts / Media Controller

Spotify Linux version:

On Ubuntu 16:04


Media keys still have no effect.

I've tried re-assigning the global shortcuts as suggested with no difference.

I spoke to Spotify support again today, just asking for an update on the fix for this.

They claimed to not know anything about the bug! Even though the last person I spoke to told me that their developers were aware of it and were working on a fix. After pointing this out, they resorted back to the 'Linux is not oficially supported' line.


I've been a premium member for years and I *only* use Linux. This issue is really frustrating and now I have no idea when/if it will be sorted.


I'll try contacting support again at a later date - maybe it was just this particular agent.


Suggested posts