Announcements

Help Wizard

Step 1

NEXT STEP

FAQs

Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...

VIEW ALL

Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...

VIEW ALL

Nothing Displayed Since Recent Update [Pop!_OS]

Nothing Displayed Since Recent Update [Pop!_OS]

I know there's a thread on this already (with the "nothingness" in the title or something), but I'm really not going through all those solutions, especially not using commands.

 

Why? - Because it's simply an "official" version on the Pop!_Shop (which is basically the Flatpak-version, or whatever you call it) that should work cause it's NOT marked as "community supported". - If it's not, and according to some people "Linux was never officially supported", well I suppose that's a Pop!_Shop issue then, but it's hard to believe since as far as I know it's always indicated when it's not official or made by the community. (Besides, the links go to the official website, not Github or anything.)

 

So what's the deal?... I've used Spotify pretty much all this year, update after update, and with the latest one (1.2.22.982.g794acc0a) it just borked itself showing nothing but a few shapes, but basically the entire interface being invisible (yet clickable). - It kind of seems like a display/driver-issue but I don't know.

 

Hope this can be fixed, cause I sure won't. I didn't install this "manually" so it should just work "out of the box" when it's on any distro's "shop". - Again, I know I should probably complain to System76 or something, but it is what it is. - But also again, it really looks like Spotify actually puts their software on these distro-shops, so... unless it's deception by a different party, it's on them to fix it.

I mean, don't feed us updates that will break it. - I thought I didn't have to worry about it since it worked without a problem dozens of times this year. But alas, of course it had to mess up at some point. - I've also reinstalled, by the way, with no difference.

Reply
4 Replies

I had this exact issue, it was fixed for a little while when I changed my display scaling on my monitor, but then still failed to work the next time I launched it. I also uninstalled and reinstalled with no avail.

I installed spotify via snap which is working perfectly for me now, but I'm sad I can't pin it to my toolbar now. I'm also waiting until the version on the pop shop is fixed.

Update: I actually can pin it to my toolbar im just an **bleep** and didnt realize it LOL

the same thing is happening for me as well! still haven't found a solution, either.

 

edit: i've found a solution! per reddit: delete the folder ~/.var/app/com.spotify.Client/cache -- you might have to log back in again, but i didn't.

Thank you very much. I also tried removing and installing the app, and didn't work. Removing the cache simply solved the issue.

Suggested posts