Announcements

Prevent spotify from playing any radio songs

Solved!
Reply

Prevent spotify from playing any radio songs

nmathew89
Casual Listener

My spotify automatically starts playing radio stations after each playlist is done playing. How do i turn this off? I don't want to listen to the radio and it's especially annoying because I listen to songs before I go to sleep but spotify keeps playing songs all night because it immediately starts playing songs from a "radio station based on my playlist".

1 ACCEPTED SOLUTION

Accepted Solutions
Solution!

Re: Prevent spotify from playing any radio songs

Eldorado
Music Fan

Found the solution: In the settings you can turn off "autoplay" which stops starting the radio.

Would like to know why it suddenly changed on all my devices, but with this I could stop that behavior again, luckily 🙂

View solution in original post

15 Replies

Re: Prevent spotify from playing any radio songs

Kookjes
Music Fan

Hi!

 

Do you have a premium subscription or a free subscription? Becausewhen using the free version, Spotify will autoplay radio after your playlist ended.

 

Hope this helped,

Jelmer

Re: Prevent spotify from playing any radio songs

nmathew89
Casual Listener

I have a premium subscription.

Re: Prevent spotify from playing any radio songs

OhJohnNo
Newbie
I also have a premium subscription. I am still having this problem. Can find no way to turn it off.

Re: Prevent spotify from playing any radio songs

yellowhammer13
Casual Listener
Premium subscription - same issue. It's really annoying. It should be somewhere in option, but it isn't anywhere... It's frustrating.

Re: Prevent spotify from playing any radio songs

Eldorado
Music Fan

Anyone found a solution? It is annoying. Have this issue for 2 days now and want to turn it back to the old behaviour.

Re: Prevent spotify from playing any radio songs

ErikG
Roadie
Does repeat solve this issue? Although this will continue your playlist instead of ending.

Re: Prevent spotify from playing any radio songs

Eldorado
Music Fan

Repeat ends in repeating the album, as one would expect. Helps a bit, but still I would prefer to totally stop playing when the album reached its end.

I am wondering what caused this different behaviour as I was only using Spotify on another Android phone. Since then all other Android phones took over this behaviour. My Windows desktop PC still works fine and normally... strange...

Solution!

Re: Prevent spotify from playing any radio songs

Eldorado
Music Fan

Found the solution: In the settings you can turn off "autoplay" which stops starting the radio.

Would like to know why it suddenly changed on all my devices, but with this I could stop that behavior again, luckily 🙂

View solution in original post

Re: Prevent spotify from playing any radio songs

ninjac
Newbie

Thanks 🙂

SUGGESTED POSTS