Spotify crashes on start Linux Mint 18

Reply

Spotify crashes on start Linux Mint 18

draconicrose
Regular

Hello. I've recently installed Linux Mint 18, upgrading from a Linux Mint 17 installation. I reinstalled Spotify but while it worked perfectly on 17, it now crashes on startup. 

 

  1. Your device and operating system:  Linux Mint 18 Cinnamon (Desktop)
  2. Type of Spotify account you have (Free/ Premium): Premium
  3. The app version of Spotify you’re using: The latest in the repo.
  4. Brief description of the issue: Spotify crashes on start.
  5. Steps to reproduce the issue: Start Spotify. 

Edit: I've already gone through the troubleshooting steps, on the page where I got the template questions from.

21 Replies

Re: Spotify crashes on start Linux Mint 18

Rock Star 22
Rock Star 22

@draconicrose

 

There are not many of us, Linux users, in the community.

 

Try posting in this thread. It's where most Linux users hang out:

 

https://community.spotify.com/t5/Help-Desktop-Linux-Windows-Web/Troubleshooting-Linux-Spotify/m-p/13...

 

https://community.spotify.com/t5/Help-Desktop-Linux-Windows-Web/Linux-Spotify-client-1-x-now-in-stab...

 

osorniosRock Star 22
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

Re: Spotify crashes on start Linux Mint 18

durin
Roadie

Delete folder /home/draconicrose/.cache/spotify/ and try again.

Re: Spotify crashes on start Linux Mint 18

draconicrose
Regular

I've already done that.

Re: Spotify crashes on start Linux Mint 18

carlolf
Regular

Was there any solution?

Just today, I also met a crash when starting Spotify. Strange, because it worked for me at least one year. I did regular updates, when there were new ones. I'm working with Mint Linux 19.1 and the latest kernel.

Re: Spotify crashes on start Linux Mint 18

carlolf
Regular

I have detected the cause of the crash:

PLuto kernel: traps: Curl Thread[4751] general protection fault ip:7fdc378e3da7 sp:7fdbbbffd140 error:0 in libcurl-gnutls.so.4.5.0[7fdc3789d000+60000

But for me, that does not help me :-)

Re: Spotify crashes on start Linux Mint 19.1

carlolf
Regular

Today I installed the latest release, offered in Mint Linux 19.1. I hoped this would fix, but there is still:

Jul 22 19:40:40 PLuto kernel: Curl Thread[5711]: segfault at 544d472030 ip 00007fa717f46cde sp 00007fa6b1ff8810 error 4 in libc-2.29.so[7fa717ee9000+173000]

This is my system: 

Host: PLuto Kernel: 5.1.16-050116-generic x86_64 bits, Distro: Linux Mint 19.1 
libcurl3-gnutls Version (7.64.0-2ubuntu1)

Re: Spotify crashes on start Linux Mint 19.1

carlolf
Regular

Today I installed Linux 5.2.3. After reboot, I ran Spotify. It crashes with the same fault as with Linux 5.1.x.

Jul 26 12:47:50 PLuto kernel: Curl Thread[1892]: segfault at 55 ip 00007f31cfac1cde sp 00007f316d7f7810 error 4 in libc-2.29.so[7f31cfa64000+173000]

Re: Spotify crashes on start Linux Mint 19.1

dlu
Gig Goer

I am not familiar with Linux Mint, but started a docker "tara" container and upgraded to "tessa", which is the codename for 19.1 according to the website. However, even after the upgrade the shipped libc version is not 2.29 but 2.27.  So I am confused right now about your installation. What is the output of "apt policy libc6"?

Re: Spotify crashes on start Linux Mint 19.1

carlolf
Regular

Yes, it seems somehow strange when I look at the

apt policy libc6

This is the output:

  Installiert:           2.29-0ubuntu2
  Installationskandidat: 2.29-0ubuntu2
  Versionstabelle:
 *** 2.29-0ubuntu2 500
        500 http://de.archive.ubuntu.com/ubuntu disco/main amd64 Packages
        100 /var/lib/dpkg/status
     2.27-3ubuntu1 500
        500 http://de.archive.ubuntu.com/ubuntu bionic/main amd64 Packages

Two versions of the library?

SUGGESTED POSTS