Help Wizard

Step 1


Spotify crashes on start Linux Mint 18

Spotify crashes on start Linux Mint 18

Hello. I've recently installed Linux Mint 18, upgrading from a Linux Mint 17 installation. I reinstalled Spotify but while it worked perfectly on 17, it now crashes on startup. 


  1. Your device and operating system:  Linux Mint 18 Cinnamon (Desktop)
  2. Type of Spotify account you have (Free/ Premium): Premium
  3. The app version of Spotify you’re using: The latest in the repo.
  4. Brief description of the issue: Spotify crashes on start.
  5. Steps to reproduce the issue: Start Spotify. 

Edit: I've already gone through the troubleshooting steps, on the page where I got the template questions from.

21 Replies



There are not many of us, Linux users, in the community.


Try posting in this thread. It's where most Linux users hang out:


osorniosSpotify Star
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

Delete folder /home/draconicrose/.cache/spotify/ and try again.

I've already done that.

Was there any solution?

Just today, I also met a crash when starting Spotify. Strange, because it worked for me at least one year. I did regular updates, when there were new ones. I'm working with Mint Linux 19.1 and the latest kernel.

I have detected the cause of the crash:

PLuto kernel: traps: Curl Thread[4751] general protection fault ip:7fdc378e3da7 sp:7fdbbbffd140 error:0 in[7fdc3789d000+60000

But for me, that does not help me 🙂

Today I installed the latest release, offered in Mint Linux 19.1. I hoped this would fix, but there is still:

Jul 22 19:40:40 PLuto kernel: Curl Thread[5711]: segfault at 544d472030 ip 00007fa717f46cde sp 00007fa6b1ff8810 error 4 in[7fa717ee9000+173000]

This is my system: 

Host: PLuto Kernel: 5.1.16-050116-generic x86_64 bits, Distro: Linux Mint 19.1 
libcurl3-gnutls Version (7.64.0-2ubuntu1)

Today I installed Linux 5.2.3. After reboot, I ran Spotify. It crashes with the same fault as with Linux 5.1.x.

Jul 26 12:47:50 PLuto kernel: Curl Thread[1892]: segfault at 55 ip 00007f31cfac1cde sp 00007f316d7f7810 error 4 in[7f31cfa64000+173000]

I am not familiar with Linux Mint, but started a docker "tara" container and upgraded to "tessa", which is the codename for 19.1 according to the website. However, even after the upgrade the shipped libc version is not 2.29 but 2.27.  So I am confused right now about your installation. What is the output of "apt policy libc6"?

Yes, it seems somehow strange when I look at the

apt policy libc6

This is the output:

  Installiert:           2.29-0ubuntu2
  Installationskandidat: 2.29-0ubuntu2
 *** 2.29-0ubuntu2 500
        500 disco/main amd64 Packages
        100 /var/lib/dpkg/status
     2.27-3ubuntu1 500
        500 bionic/main amd64 Packages

Two versions of the library?

the last output from the crash listet the error occuring in libc. But before, and now after running the latest kernel 5.2.5,

journalctl -f

prints this output after the crash of Spotify:

Jul 31 10:21:20 PLuto kernel: traps: Curl Thread[1844] general protection fault ip:7f72d0bc56b1 sp:7f7260ff6848 error:0 in[7f72d0b9a000+60000]

I don't know how libcurl-gnutls is related to libc6 and if it is somehow randomly showing the error in one of the libraries.

The segfault in libcurl3-gnutls is typical for the disco package version. See the workarounds in

I am running a fresh install of Pop!_OS 19.04 (an Ubuntu-flavour by the Linux hardware manufacturer, System76), and I ran into the same problem after installing Spotify. Please find my system/hardware specs below:


Linux pop-os 5.0.0-21-generic #22+system76-Ubuntu SMP Tue Jul 16 19:57:52 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

Please excuse me, I am a Linux newbie, and I don't know how to collect the error messages, dumps, or whatever they're called 😛


Anyway, I've ran Spotify on my Pop!_OS 18.04 before the upgrade, and I've never had any problems. Now, Spotify closes on the very instant it's opened!


Is there any fix yet? If there is, could you please make the instructions newbie-friendly? 🙂 Thanks!

I followed the suggestions from and this solved my problem with Spotify.

@carlolf wrote:

I followed the suggestions from and this solved my problem with Spotify.

Hi there, carlofl! I managed to download the three .deb files by running the curl-commands (in the instructions, the last one was missing `curl` in front of the code). However, running the last command, `sudo dpkg -i ~/Downloads/libcurl3-gnutls_7.64.0-4_amd64.deb ~/Downloads/libgnutls30_3.6.8-2_amd64.deb ~/Downloads/libgnutls30_3.6.8-2_i386.deb`, yields with the following error message:


panteroide@ubuntu:~$ sudo dpkg -i ~/Downloads/libcurl3-gnutls_7.64.0-4_amd64.deb ~/Downloads/libgnutls30_3.6.8-2_amd64.deb ~/Downloads/libgnutls30_3.6.8-2_i386.deb
[sudo] password for panteroide: 
(Reading database ... 183422 files and directories currently installed.)
Preparing to unpack .../libcurl3-gnutls_7.64.0-4_amd64.deb ...
Unpacking libcurl3-gnutls:amd64 (7.64.0-4) over (7.64.0-2ubuntu1.1) ...
Preparing to unpack .../libgnutls30_3.6.8-2_amd64.deb ...
Unpacking libgnutls30:amd64 (3.6.8-2) over (3.6.5-2ubuntu1.1) ...
Selecting previously unselected package libgnutls30:i386.
Preparing to unpack .../libgnutls30_3.6.8-2_i386.deb ...
Unpacking libgnutls30:i386 (3.6.8-2) ...
dpkg: dependency problems prevent configuration of libcurl3-gnutls:amd64:
 libcurl3-gnutls:amd64 depends on libssh2-1 (>= 1.7.0); however:
  Package libssh2-1 is not installed.

dpkg: error processing package libcurl3-gnutls:amd64 (--install):
 dependency problems - leaving unconfigured
Setting up libgnutls30:amd64 (3.6.8-2) ...
dpkg: dependency problems prevent configuration of libgnutls30:i386:
 libgnutls30:i386 depends on libgmp10 (>= 2:6.0.0).
 libgnutls30:i386 depends on libc6 (>= 2.28).
 libgnutls30:i386 depends on libhogweed4 (>= 3.4.1~rc1~).
 libgnutls30:i386 depends on libidn2-0 (>= 2.0.0).
 libgnutls30:i386 depends on libnettle6 (>= 3.4~).
 libgnutls30:i386 depends on libp11-kit0 (>= 0.23.11).
 libgnutls30:i386 depends on libtasn1-6 (>= 4.12).
 libgnutls30:i386 depends on libunistring2 (>= 0.9.7).

dpkg: error processing package libgnutls30:i386 (--install):
 dependency problems - leaving unconfigured
Processing triggers for libc-bin (2.29-0ubuntu2) ...
Errors were encountered while processing:

Any ideas on how to proceed? 😞

When I try to open Spotify though terminal, I get the following error message:


panteroide@ubuntu:~$ spotify
spotify: error while loading shared libraries: cannot open shared object file: No such file or directory

Sorry Panteroide , I am not a Linux guru, so I cannot really give you good tips. Maybe there is someone other here listening?

This is a rather old thread from 2016. I'd suggest posting a new one with your current distro specifications, as it looks all of us are having trouble with different distros, and configurations.

osorniosSpotify Star
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

Interesting. I was just about to install the missing library,, through terminal:


sudo apt install libssh2-1


However, on the last second I changed my mind and decided to try finding the library through Synaptic Package Manager instead. Well, I couldn't find the library, but after opening I got an error message about two broken packages. I decided to fix the broken packages, and return to my original plan as libssh2-1 was not found there.


However, after running


sudo apt install libssh2-1


I was told that the packages are already installed and up-to-date (?!?). Well, if not installing the abovementioned package, at least fixing the broken packages through Synaptic Package Manager helped to resolve the problem ... yeah, packages that I never knew to be broken in the first place! 🙂


Thanks for your help, and hopefully this helps someone with the same problem running Linux Ubuntu Pop!_OS 19.04! Cheers!

Same error here, Spotify randomly crashes during playing music.


Sep 19 10:35:18 berni kernel: [1367105.687295] Core Thread[10149]: segfault at a3 ip 0000000003401a26 sp 00007fadea7f9f50 error 4 in spotify[2288000+2012000]
Sep 19 10:35:18 berni kernel: [1367105.687312] Code: fb 48 8b 31 48 85 f6 74 3e 49 89 ce 89 55 cc 48 89 5d d0 44 89 fb 44 8a 7d 10 48 83 c6 28 48 8d 7d 88 e8 0d ac e8 fe 49 8b 06 <80> b8 a3 00 00 00 00 74 40 0f b6 d3 48 8b 7d d0 4c 89 e6 e8 42 02

Spotify 1:

Linux Mint 19.2 Tina


When will this be fixed?

Suggested posts