Spotify is opening on startup and there is no option listed in the advances settings, to turn it off

Solved!
Reply

Spotify is opening on startup and there is no option listed in the advances settings, to turn it off

viktormatrai
Casual Listener

Hi!

As the title tells it: the desktop app opens, after starting up the laptop. In the advanced settings  there is no option to turn this feature off. There's just a blank space under the 'Startup and Window behaviour'. I also tried to solve it in the local prefs file, from command line, but it reverts itself after saving. 

Please help to solve this bug, or just modify the code for autostart = false. It's a silly feature anyway.

Screenshot from 2019-08-29 12-51-39.png
1 ACCEPTED SOLUTION

Accepted Solutions
Solution!

Re: Spotify is opening on startup and there is no option listed in the advances settings, to turn it

Rising Star 12 ArtGravity
Rising Star 12

I can definitely see where this would be inconvenient.

 

If this were happening on my Ubuntu laptop, the first place I would check is the Ubuntu Startup Application Preferences to see if it is getting launched there. If it is, it should be as simple a fix as just unchecking it.

 

If it's not being launched at startup from there, some additional information might be helpful.

 

What version of Ubuntu are you using?

Are you using the official Snap app?

What desktop environment are you using?

ArtGravityRising Star 12
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.
2 Replies
Solution!

Re: Spotify is opening on startup and there is no option listed in the advances settings, to turn it

Rising Star 12 ArtGravity
Rising Star 12

I can definitely see where this would be inconvenient.

 

If this were happening on my Ubuntu laptop, the first place I would check is the Ubuntu Startup Application Preferences to see if it is getting launched there. If it is, it should be as simple a fix as just unchecking it.

 

If it's not being launched at startup from there, some additional information might be helpful.

 

What version of Ubuntu are you using?

Are you using the official Snap app?

What desktop environment are you using?

ArtGravityRising Star 12
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

Re: Spotify is opening on startup and there is no option listed in the advances settings, to turn it

viktormatrai
Casual Listener

Thanks! 
Meanwhile I found this as a solution. 

Anyways it is a bit weird that by nature is autostarting and it can't be swithed off from the app itself. 

For your questions:

What version of Ubuntu are you using? - 18.04

Are you using the official Snap app? - yes, the latest.

What desktop environment are you using? - gnome

SUGGESTED POSTS