Help Wizard

Step 1



Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...


Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...


W:GPG error: stable InRelease

W:GPG error: stable InRelease

W:GPG error: stable InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 4773BD5E130D1D45, E:The repository ' stable InRelease' is not signed.








Operating System

Linux Mint 19.2


My Question or Issue

The repository key is not signed. Can someone please fix this.


4 Replies

Is this a new installation, or has it been working o.k. and suddenly started having problems?
Is this install via apt/deb package or did you use some sort of app store, e.g. snap package?
If new installation, did you install a public key?

In my debian using apt/deb installation I made the following notes (which might be out of date now) in my spotify.list file:

# 1. Update sources.list or spotify.list file:
# deb stable non-free
# 2. Install public key:
# apt-key adv --keyserver --recv-keys 94558F59
# apt-key adv --keyserver hkp:// --recv-keys D2C19886
# apt-key adv --keyserver hkp:// --recv-keys A87FF9DF48BF1C90
# 3. Run apt-get update
# apt-get update
# 4. Install spotify client software.
# apt-get install spotify-client

I'm guessing only the latest "apt-key adv --keyserver" public key is needed, so most likely the command should be something like:
sudo apt-key adv --keyserver hkp:// --recv-keys 4773BD5E130D1D45

Thanks, I tried all four, this is the one that worked for me 1/13/2020

# apt-key adv --keyserver hkp:// --recv-keys A87FF9DF48BF1C90


 This last one did NOT work:

sudo apt-key adv --keyserver hkp:// --recv-keys 4773BD5E130D1D45


Thanks again for the post!

Hi, sorry but I'm new to linux. Do you know why you have put hashes at the beginning of each command doesn't that comment the commands out? I've tried using deb without the hash and the terminal says it's not a command. Then I tried to install deb with apt but it says there isn't a package. Thank you for your time.

There can be several reasons someone might put hashes at the beginning of each command.


1) This is sometimes used to signify that the commands are executed as the root user, because it is common for the root user command prompt to use the # symbol.


2) In my post above, I was posting the contents of a config file, where I had made a note of my actual steps to install spotify in debian. In this case, the hashes were used to ensure that the notes were treated as comments and not part of the configuration.


Regarding your last comment, "tried to install deb with apt but it says there isn't a package", it might be better to post the steps and actual error messages.


It sounds like you have not created or edited your /etc/apt/sources.list.d.spotify.list


That file should contain the following line:

deb stable non-free


The official instructions can be found here:


You probably need to follow the last section for Debian/Ubuntu


Suggested posts