Help Wizard

Step 1


Wrong rendering in artist font

Wrong rendering in artist font







Operating System

Arch Linux


My Question or Issue

I'm using the web player on a fresh install of Arch Linux + Google Chrome, and I'm facing a strange issue. It seems like the font used to display the song artist renders in a really weird manner. Some examples:


Whenever I hover over that string, it gets "fixed", but gets "broken" again if I move the cursor around the UI. I have the console filled with this log: "The resource was preloaded using link preload but not used within a few seconds from the window's load event. Please make sure it has an appropriate `as` value and it is preloaded intentionally."


Any ideas?


Thanks in advance!

13 Replies

Still having this issue with Fedora Linux 37

Screenshot from 2023-04-24 14-57-56.png

the problem is the eSMjmiD29Ox35O95waw6 class of the css, you can create a custom css to fix the problem, hoping for an official fix soon




.eSMjmiD29Ox35O95waw6 {
    -webkit-mask-image: none !important;






on chrome and firefox you can use stylus extension.

there is also a way to fix the desktop client but i don't know if it's allowed to say the name of the tool to do it


video of the problem attached and how fix problem on chrome/chromium with stylus (it's the same on firefox)


Have the same issue when using the Spotify client on Ubuntu 22.04:


Screenshot from 2023-05-05 09-51-05.pngScreenshot from 2023-05-05 09-50-08.png

I also have this problem on two machines running Gentoo.

spotify 1.2.8


on desktop clients the one to edit is





.main-trackInfo-overlay {
    -webkit-mask-image: none !important;




Before and after


How can I edit the css config of the desktop client?

use spicetify

Having the same problem for weeks. OpenSUSE Tumbleweed




I was able to fix it by adding --disable-gpu flag when launching Spotify.


- Alternatively, I added the flag in my spotify.desktop file


I am running Spotify trough Faltpak on Ubuntu 23.04 and I can confirm the same issue.
Adding --disable-gpu to the flatpak "command" it's not solving the issue.

Strange, that actually works for me.  I can't believe this hasn't been fixed yet.

Can confirm this issue, installed from the aur. Adding --disable-gpu fixed it.

This worked for me, thank you. I'm using the PWA via Chromimum on linux.

Suggested posts