Announcements

Music won't play after resuming from sleep mode

Music won't play after resuming from sleep mode

Nebulizer

Plan

Premium

Country

United States of America

Device

MacBook Air (2020, M1)

Operating System

macOS Big Sur 11.4

My Issue

Closing the MacBook Air's lid and putting it into sleep mode (while music is playing on Spotify) results in music pausing. This behavior is expected. The problem occurs is when you open the MacBook back from sleep mode and try to play the music again. You are met with a "Can't play the current song" error. This occurs on both the Apple Silicon Beta version and latest version (1.1.62.583.gdac868ed-a). 

How to reproduce

1. Open Spotify and play any track

2. Close MacBook Air lid whilst having music playing

3. Open MacBook lid, unlock Mac if necessary, and resume music. Issue can be observed.

 

I recorded the issue on my phone but the file was was too large to upload here, I instead opted to upload it on Google and share using this link: 

 

https://drive.google.com/file/d/1NwP0ZCTOEd_CJhqhgUtcvyofaAVKT-x6/view?usp=sharing

 

I hope this is useful information for developers to look into and hopefully come to a resolution.

Reply
16 Replies

Elena

Hey @Nebulizer!

 

Thanks for the report!

 

It might be a good idea to try some more troubleshooting steps here.

 

We can suggest that you try updating your computer's drives to make sure you have the latest version.

 

It's also worth trying to disable hardware acceleration in the app:

  1. Click Edit in the menu bar. Select Preferences.

  2. Scroll down and uncheck Hardware acceleration.

  3. Restart Spotify.

If this still doesn't solve, could you please post your update in the Idea post that we have about the Beta version of the app.

 

We appreciate your cooperation on this. Keep us in the loop 🙂

ElenaModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

dejp1993

I also have this exact problem on my M1 MacBook Pro (2020). I have tried uninstalling and reinstalling from https://www.spotify.com/us/download/mac/ several times, but the problem persists.

 

Side note, I don't see any options for toggling Hardware Acceleration in the Mac app's Preferences. Also Preferences are not in the location described - those instructions seem to be for Windows.

Jeremy

Hi there @dejp1993,

 

Thank you for your reply and for the troubleshooting that you've done so far.

 

If you haven't already, can you download Spotify from App Store?

We'll be on the lookout for your reply.

 

Take care!

JeremyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂

vinimsoliveira

I'm facing the same issue, bought a new macbook this year and ever since I have to reboot spotify every time my mac goes into sleep mode. 

 

There's no Spotify app on App Store for macos, terrible job you guys are doing advising people, two answers and none of the make any sence. 

OscarDC

Hey @vinimsoliveira,

 

Thank you for reaching out to the Community and welcome. 


We understand where you're coming from. However, just to make sure - did you use these steps for a clean reinstall as suggested before? They are more thorough than a regular install and you can make sure the cache is not causing this issue.

 

If so and the issue persists, would you mind letting us know the troubleshooting steps you've tried so far? This is to avoid suggesting steps that you may have done before.


Lastly, to have a better look at the issue, could you include the model and OS version of your Mac, along with the Spotify version you're currently running?

 

We'll be waiting for your response.

OscarDCModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

dejp1993

I just saw your post this morning and tried the clean reinstall steps. At lunch time my MacBook went to sleep and Spotify was frozen when I tried to resume. I had to Force Quit it.

OscarDC

Hey @dejp1993,

 

Thank you for keeping in touch and for the info you shared.


To continue investigating this case, could you confirm if you tried with the App store version as suggested previously by @Jeremy

 

If so, and the issue persists, could you include the OS version of your Mac, along with the Spotify version you're currently running? This will give us a better look at the issue.

 

Lastly, if you haven't tried yet, could you try with a different WiFi network to see if it makes any difference? In case you don't have another network available, you can use a mobile data hotspot to try it.

 

We'll be on the lookout. 

OscarDCModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

dejp1993

As vinimsoliveira mentioned, there is no App Store version for Mac. The only App Store version is iOS.

 

macOS Monterey, 12.4

MacBook Pro (13-inch, M1, 2020)

 

Spotify for macOS (Apple Silicon)
1.1.89.862.g94554d24

 

I've had this issue for > 1.5 yrs, since I got this M1 Mac. It happens with my Verizon hot spot, too.

Yordan

Hi @dejp1993!

 

Just to double-check, did you try disabling the Hardware Acceleration? You can find it in the app's Settings > Compatibility or by clicking Spotify on the menu bar > Hardware Acceleration.

 

Something else you can try out is deleting the prefs file, which holds information about the currently logged it account:

  1. Open Finder on your Mac and click Go > Library (if you don't have hidden folders enabled, press the option key first and it should appear).
  2. Go to Application Support > Spotify.
  3. There you'll find a file called prefs, simply delete it.
  4. While in the Spotify folder, you'll also find a Users folder. Open it and delete its contents as well.
  5. Restart the Spotify app.

Note that you'll be logged out and your settings will be reset, so you'll have to adjust them again. If you had music downloaded for offline listening, you'll have to re-download it as well. Your library, however, will not be affected, so no worries there.

 

Keep us posted on this. Cheers!

YordanModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

dejp1993

Hey Yordan,

 

Deleting the prefs and Users didn't help. That seems like a good general troubleshooting step though, so I'll tuck that away in my back pocket.

 

I also tried disabling the hardware acceleration via the Menu bar -> Hardware Acceleration, and so far that seems to be doing the trick! I'll test more over the next few days and report back here.

 

Thanks for your help!

dejp1993

Update: unfortunately the freezing is still happening, even with Hardware Acceleration turned off 😞

Eni

Hey there @dejp1993

 

Thanks for all the info you've sent so far. 

 

Would you mind checking if the OS of your computer is up to date?

 

On another note, could you let us know if this is only happening with Spotify or with other streaming apps as well?

 

Additionally, we suggest that you head over to Settings > toggle on Show Local Files > toggle off all the sources that appear there > toggle off Show Local Files. Afterwards, restart your PC and see if that made the trick. 


We'll be on the lookout.

EniModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“Music acts like a magic key, to which the most tightly closed heart opens.”– Maria von Trapp

dejp1993

Yes, my OS is up to date (now 12.5).

 

Only Spotify.

 

"Settings" where? MacOS has "System Preferences," and Mac Spotify has "Preferences." No "Settings." 

 

At this point, I think we've covered all the basic and obvious things. Is it possible to send you some debug logs or something?

Eni

Hey @dejp1993

 

Thanks for you reply. 

 

Sorry for the confusion. You can find the steps we suggested in the app settings. 

 

Let us know how it goes.

EniModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“Music acts like a magic key, to which the most tightly closed heart opens.”– Maria von Trapp

dejp1993

Ah from the Menu bar -> Spotify -> Preferences, I do see Show Local Files. It was already toggled off.

Elena

Hey @dejp1993,

Thank you for keeping in touch and for the info you shared. 


We tried testing it from our end and we're not able to reproduce this behavior.
The thing we can suggest is to use Safe Mode on your MacBook. Safe Mode is a way to start up your Mac, so it performs certain checks, repairs, emptying of system cache, and prevents some software from automatically loading. 
You can try it and test if the same behavior continues with Spotify, restart it and log in as usual to see if that resolves the problem.
Here are the appropriate steps for using Safe Mode.

Hope that helps.

ElenaModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Suggested posts

Env: prod