Stuttering Audio Streaming To Apple TV Via AirPlay

Solved!
Reply

Stuttering Audio Streaming To Apple TV Via AirPlay

blacknotes
Visitor

I'm trying to play music on an Apple TV via AirPlay (audio only, not mirroring).  The audio often stutters.  I'm using Spotify Premium.

 

The Mac and Apple TV are connected to the same home WiFi network.  The WiFi network is not busy and my broadband is quite fast (>50Mbs download speed).  I don't think it is a network issue because things work fine if I use Spotify on my iPhone.

 

My computer is a mid-2009 MacBook Pro, 2.53 GHz Intel Core 2 Duo processor with 8GB RAM.  It is not busy with CPU or swapping.

 

Please can anyone suggest how I might fix this?

 

2 ACCEPTED SOLUTIONS

Accepted Solutions
Solution!

ollipuljula
Casual Listener

Try to disable Wifi multimedia (WMM) from your router's WLAN settings

View solution in original post

Solution!

scottkundla
Newbie
35 Replies

ach247
Newbie
Having the same issue when pushing from iPhone app. Spotify support was not able to provide a fix when I contacted them on twitter. I'd really like to get this sorted as using Airplay is a big part of my home audio setup.

TECH101
Gig Goer

It works fine here.

 

The only difference is my Apple TV is canled to my router, but the Mac is on Wi-fi..  No skipping here..

 

802.11g should be fast enough.

prunier84
Newbie

Hi,

 

Does anyone have an update on this?

 

So annoying! any help welcome. spotify stuttering on airplay  from iphone but other airplay apps fine.

 

was fine on previous ioS

Jester6969
Visitor

My system worked perfectly for over three weeks, no stuttering. Problem now makes the app useless.

Today have updated to iOS7.0.4, it doesn't seemd to have helped.

Any other ideas

Solution!

ollipuljula
Casual Listener

Try to disable Wifi multimedia (WMM) from your router's WLAN settings

View solution in original post

user-removed
Not applicable

I was just about to purchase a subscription when I came across this issue as well. FOr this reason alone, Spotify will not get my loot. 

emaw
Newbie

+1 for a fix

tolsky
Newbie

I had this problem - fixed it after reading this guide

 

there are lots of potential fixes in this article, what worked for me was simply turning OFF bluetooth (System preferences) on my mac - the stuttering went away.

Am using MBPr 2012 running Spotify Premium, I'm selecting my AppleTV by option-clicking on my speaker icon, as Spotify on a mac doesn't let you use Airplay like an iOS device can. 

voidhawker
Newbie

I've had problems with streaming audio to my AppleTv, either from a Macbook Pro or from an iPhone. The quality is very very low, and it oftens stutters for the first 10 - 20 seconds. It's the only option I've found that works with spotify though. Previously I used Chromecast + Google Music, and this was much more flexible, and the quality was better.

 

 

Zach3827
Newbie

Wow thanks!!! that Fixed mine!! the WMM is now disabled and no problems! thanks!!

undelete
Casual Listener

My WMM was already disabled, however there was a setting called "Power Save Support" in the same page that somehow was related to WMM as well, so I disabled that and now it seems to work fine. However I guess that Spotify still have to reprogram this part since all other applications works fine with WMM (or any of it's sub settings) enabled. However, thanks for the tip ollipuljula!

 

 

Edit: 10 minutes after I wrote this...of course it started to stutter with Spotify again... 🙂

Jasper100
Newbie
The problem has eluded me for two years. This totally solved it. Thanks!

jmellars
Newbie

@tolsky 's bluetooth tip worked for me perfectly! No idea how you figured that out. Nice.


@tolsky wrote:

I had this problem - fixed it after reading this guide

 

there are lots of potential fixes in this article, what worked for me was simply turning OFF bluetooth (System preferences) on my mac - the stuttering went away.

Am using MBPr 2012 running Spotify Premium, I'm selecting my AppleTV by option-clicking on my speaker icon, as Spotify on a mac doesn't let you use Airplay like an iOS device can. 


 

acondiff
Regular
Thank you so much! I have been looking for a solution to that for a few years now. That did the trick. You are awesome! 🙂

mhlgoossens
Newbie

thanks a lot!! been looking for a solution for a long time now and disabling QoS solved it for me 🙂

michaeldiener
Casual Listener

I've had success with turning off WMM. I've also had success with changing my network on both my phone and my apple tv from the 5 Ghz band to the 2.4 Ghz band and have had success.

georgeboy1
Newbie

**bleep**, thank you sooo much for this tip!

Since weeks I tried to figure out where the heck this problem is.

From iPhone and iPad Airplay worked just fine, but from my Macbook Pro I had always this super annoying stuttering.

Your Tip solved it for me. I disabled "Mediaserver" in the settings of my router (FritzBox) and finally it works nicely and flawless...

thanx again.

Thehappybroker
Newbie
Thank you this worked for me also 👍

lngwlk24vr
Newbie

Thanks. Would have this same issue watching movies or playing music.... turning off Bluetooth fixed. Keeps it simple ...

SUGGESTED POSTS