Help Wizard

Step 1



Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...


Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...


Amazon Echo says "Connecting" but won't

Amazon Echo says "Connecting" but won't






Samsung Galaxy S10e


Operating System

Android Pi


My Question or Issue

The spotify app on my phone won't always connect to my Echo.  My wife's Galaxy s9 connects everytime, but mine is sporadic.  It won't connect everytime and I've never had an issue before.  It is the same with our Echo dot as well.


From the app, as usual I go to select devices available - then select to connect to the Echo.  It says "Connecting" but doesn't.  It started with one album in particular by Skyzoo and Pete Rock.  It can't be the album?  My wife's phone connects with the same album and others.  


If I connect and play a podcast, it works for that but not all albums after.  I am totally up to date with Spotify and app, as well as Android etc.  There has to be a bug somewhere.  The spotify app works on the phone with headphones or bluetooth. 


The amazon alexa app is up to date with Spotify set as default app.  I did a full re-install of both apps, cleared cache from both apps as well phone as per what I can see on message boards.  It all worked last night, but now back to not connecting to every album via the echo - but works without it via headphones and bluetooth.


Please can someone help as this is driving me mad!!!!!  Thanks in advance

6 Replies

Afraid I can't help but can confirm I have the same issue. Songs seem to play fine most of the time but occasionally stop for no reason. If I ask Alexa to play Spotify she announces that she is but nothing happens. If I open the app on my phone and try to connect to any one of my echo dots or any of the groups of echo dots I get the 'Connecting' message. Asking Alexa to do anything else (radio stations,Amazon music etc) works fine, it just seems to be Spotify that ifs affected,

Thanks for this. Spotify can't fix the issue as it doesn't replicate for them. It has to be an Amazon / Alexa issue with spotify.

It works for me if you ask it to play the album - then it will let you control the album via your phone, but not a new album. Strange.
Works fine for podcasts or playlists though. I've given up and may well just get another speaker, maybe not even with Alexa.

Try connecting VIA Bluetooth to instead of just WiFi! 

Wow, neat. My entire post was deleted because I had a question mark in my message tag. That's an interesting feature.


I just ran into this issue with my second gen Echo on both my Galaxy S8+ and iPad pro. Tried restarting both with no results, so I unplugged my Echo for about a minute. Once it reconnected everything was working correctly again.


I know you've probably fixed this by now, but this should help anyone who stumbles across this on google like I did.

I know the original person said he tried this but I was having the same issue with my Echo Dot and my Google Home Mini. I tried restarting my router and my iPhone but that didn’t work. I deleted the Spotify app off my phone, reinstalled it and then I was able to connect to both speakers. Hopefully this doesn’t become an ongoing issue. Sometimes I try to connect and it won’t work but if I try a little bit later it connects. I have no idea what the issue is with the Spotify app. Maybe they should look into this since it’s been happening to a lot of people for quite a while according to a simple Google search. 

Thanks for the advice, the solution was as you said disconect Alexa for a minute and reconect it and everything work fine again.

Suggested posts