Announcements

Audio lags when online

Solved!
Reply

Audio lags when online

Casual Listener

Plan

Premium

Country

Austria/Germany

Device

2 Desktop Devices

Operating System

Windows 10 Pro


My Question or Issue
Today i decided to get pretty angry:
Since 1y or so my spotify on win10 Desktop Client startet to lag/stutter/clutter/clitch sometimes. I thought it was bc of my old usb DAW. From time to time it got worse and i tried different device drivers, tried several suggestions out of this community, checked every hint, but no! Even a windows reinstall didn't change a thing. That time i was on LAN, since 3 months i am on wifi, both connections were able to stream full hd movies without any problems.
I was about to give up and wait for an update, but then i started using spotify at work and i got the exactly SAME behaviour, on a different device.

As far as i could analyse, things go like this:
While playing music on soptify i do several things and when the cpu load gets high, the lags do also. Sometimes it just doesn't make a noice, sometimes it's like streching audio with a factor of 10. When i start a browser (no matter if chrome, firefoxy, opera) and open a website, the lags/stutters are extreme. It happens on downloaded playlists as well as with never heard / downloaded songs.

 

BUT:
If i interrupt my internet connection, everything is fine.

 

Why is there no buffer log where we can check things like the nerd stats in youtube??
And btw: I couldn't write this message in a regular firefox tab. i had to shut down my adblocker and use a incognito tab, otherwise the page would refresh forever and take most of the cpu usage. Not very trustabel



 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Solution!

Re: Audio lags when online

Casual Listener
Guess what:
ZoneAlarm Firewall was the problem.

After uninstalling everything runs smooth.

View solution in original post

2 Replies
Solution!

Re: Audio lags when online

Casual Listener
Guess what:
ZoneAlarm Firewall was the problem.

After uninstalling everything runs smooth.

View solution in original post

Re: Audio lags when online

Moderator
Moderator

Hi there @le_mon,

 

Thanks for reaching out to the Community and welcome!

 

We're glad to know that you could find the root cause of the issue and everything is running as expected now. We appreciate you posting the solution on this thread as it might be helpful for other users as well.

 

If you have any questions or need a hand with anything else, remember that we're just a post away.

 

Have a good one 🙂

CarlosEModerator
 
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
SUGGESTED POSTS