Announcements

Help Wizard

Step 1

NEXT STEP

Disable autoplay whenever the app is launched

Disable autoplay whenever the app is launched

Whenever the app is launched on desktop now, Spotify starts playing whatever you were last listening to automatically. I'm not a fan of this, especially since it plays before the rest of the app finishes loading, so I can't even pause for the first few seconds. I looked for a way to disable this in Settings, but all of the relevant settings have nothing to do with playing on startup. 
Under Autoplay settings, there's "Autoplay similar songs when your music ends in this app" and "Autoplay similar songs when your music ends on other devices." Both of these have nothing to do with autoplaying on launch. 
Under Playback, there's "Crossfade songs," "Automix - Allow seamless transitions between songs on select playlists," and "Mono audio - Makes the left and right speakers play the same audio." These also are irrelevant to playing automatically on startup, even if the setting for disabling that would be most fitting here. 
Under Startup and Window Behavior, there's "Open Spotify automatically after you log into the computer" and "Close button should minimize the Spotify window." While it makes some sense for this kind of thing to fall under Startup settings, it's nowhere to be found here either. 
There should absolutely be a way to disable this in settings. 

playback_and_startup_settings.png
autoplay_settings.png
Reply
3 Replies

Hey there @Chiyoye

 

Thanks for reaching out about this and welcome to the Community! We moved your post from the Ideas board to the relevant Help board, where it fits better.

 

Could you let us know if this has always happened on your PC or if it started happening after a specific event such as an update?

 

On another note, does this happen when you have your headphones/speakers connected?

 

Lastly, it's well worth running a clean reinstall of the app to get rid of any cached files that might be causing trouble. If this doesn't do the trick, sending us the exact make/model, operating system and Spotify version of your PC would come in handy.

 

We'll be waiting for your reply. 

EniModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“Music acts like a magic key, to which the most tightly closed heart opens.”– Maria von Trapp

Dear Spotify

 

Is there any solution of the above mentioned problem? I have the same issue, I use it on phone (android) which is Bluetooth connected to speakers, and for me Spotify autoplays music not just on opening, but even if I pause the music and switch to another app (like browser or other music app like soundcloud), and whenever I switch back it plays instantly (which is very irritating if I'm listening music on the other app, so it cancels out) Is there any way to turn this off?

Thanks

Welcome to the thread, @Ákos!

 

Does this only happen when you're playing music on another device via Bluetooth? Could you try turning it off and playing directly on your phone to see if that changes anything?

 

We also recommend disabling Autoplay from Settings both when connected to the speakers with Bluetooth, as well as when you're not using Bluetooth. 

 

One more step you can try if the above mentioned doesn't do the trick is to even disable Allow Background Activity via your phone's settings. You should be able to find it if you go to your phone settings > Apps > Spotify.

 

Keep us updated 🙂

IvelinaModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a "Like".
Are you new to the Community? Take a moment to introduce yourself!

Suggested posts