Announcements

Having trouble seeing your Wrapped stories? To fix this, update the Spotify app to the latest version.

Find more info on our community FAQ.

Explicit Songs Fail to Play "This Song is Not Available"

Explicit Songs Fail to Play "This Song is Not Available"

Plan

Premium/Family Plan

Country

 Canada

Device

Surface Pro 3 (Windows Laptop)

Operating System

Windows 8.1

 

My Question or Issue

 

Whenever I try to play an explicit song I get a message in a blue banner at the top that says "This song is not available. If you have the file on your computer you can import it."

I've tried reinstalling spotify but the problem still remains. I am over 18 and my correct date of birth is on my profile. I've also tried the web player with the same songs, they won't play when clicked on. Is there anything else I can try to resolve this problem?

spotify issue.jpg
Reply
9 Replies

I just got the exact same thing happening today, it will play any song not marked as explicit, but any explicit song is now apparently "Not Available".

 

I've tried switching the access to explicit content on and off and on again on the mobile app, and trying to play them on my desktop through the connect feature, still no luck.

Also tried through the web player. No dice there either.

 

Anyone know what might be up with this?

 

 

Are you on a family plan by any chance? The account that's doing this is.

 

As a test, I created a free account, but the songs play fine on there.

I'm having this issue too... No option anywhere to enable/disable explicit content for the desktop app. Explicit content works fine on mobile however.

Same issue for me. 😞

Ok...I think I've fixed this. It seems that when you toggle the 'Explicit Content' via iOS app and the desktop app is running at same time (even when just playing via iOS device) the desktop app is getting a corrupted setting with respect to the setting. So, to solve it I closed the desktop app - then toggled the 'Explicit Content' via the iOS app. Re-opened the desktop app and bam, working again. 

I just tried the same thing with the Android app. It seemed to work. I'll post again if it comes up again but hopefully this solves it. Thank you so much!

Glad it worked for you too. It was really annoying me today, so I'd try a few things to try sort it out. 🙂

YES! This worked thanks so much! I can finally enjoy my songs on the desktop again! 🙂

Yes this also worked for me -

closed the desktop app, opened on my iPhone and changed the expicit settings and then it worked on my desktop as well

 

thank you!

Suggested posts