No Sound and rapid skipping - USB sound device

Solved!
Reply

No Sound and rapid skipping - USB sound device

Keydo
Casual Listener

Plan

Premium

Device

PC

Operating System

Windows 10

 

My Question or Issue

Spotify skips every song before displaying "Spotify can't play this right now. ...". Every other program works fine. It seems like Spotify is unable to use the USB Soundcard (FiiO K3 USB DAC), which is set as the standard sound device in the Windows settings.

 

Following https://community.spotify.com/t5/Live-Ideas/Desktop-Select-default-Sound-Device/idi-p/5351 to change the default sound device from "default" to "FiiO K3" does help, but when restarting the FiiO K3 the Spotify continues to "play" the song without sound. The playback only works when starting the spotify.exe with --enable-audio-graph after switching on the FiiO K3. Even then, the sound quality setting (premium) gets ignored. The FiiO K3 indicates the sound quality of Spotify with ≤ 48khz sampling rate and Windows sounds with >48khz sampling rate.

 

I want to stress that every other player works just fine. Using the FiiO K3 USB DAC as the default sound device on windows is no problem, only for Spotify.

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Solution!

Evan9500
Casual Listener

Okay, So i went into devices properties and changed Sound quality on my g6 to 16bit 48,000 hz and spotify began playing. Changed back to 32 bit 384000 hz and its working again. 

View solution in original post

5 Replies

Evan9500
Casual Listener

Having the same issue with my Creative soundblaster g6. Troubleshooting now, will keep you updated

Solution!

Evan9500
Casual Listener

Okay, So i went into devices properties and changed Sound quality on my g6 to 16bit 48,000 hz and spotify began playing. Changed back to 32 bit 384000 hz and its working again. 

View solution in original post

Sebasty
Rock Star 18
Rock Star 18

Hey @Keydo

 

It shouldn't be necessary to run Spotify with --enable-audio-graph command since Windows 10 has a section dedicated to assigning audio devices to apps in its Sound Settings.

You'll find that section by opening Settings and then clicking on System --> Sound.
Under "Other Sound Options" click on "App volume and device preferences".

 

If you don't use the onboard audio, it's safe to disable its driver in Device Manager. Sometimes this solves the issue with USB interfaces not recognised as default.

 

Lat me know how it goes 🙂

SebastyRock Star 18
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

Keydo
Casual Listener

Hi @Sebasty,

Spotify doesn't register in the Windows 10 sound settings, because it doesn't output any sound. Disabling every other sound device was the first thing I tested, which unfortunately didn't help either.

Keydo
Casual Listener

Hey @ Evan9500,

changing the bit and sampling rate in the sound device settings to 16 / 44.1 kHz enables Spotify to play again, thanks! I can’t reach anything above 192 kHz though. 352.8 kHz and 384 kHz are leading to the skipping again.

This is still a bug, because the FiiO K3 can output 32 bit / 384 kHz, but at least Spotify is usable again. I don’t think I would notice a difference anyway.

SUGGESTED POSTS