Announcements

Re: Spotify keeps opening on startup [Windows 10]

Reply

Re: Spotify keeps opening on startup [Windows 10]

siaarzh
Newbie

This is not a spotify issue, it's a Windows 10 bug that was supposed to act like a "feature":

 

Old behavior:

  • When you shut down your PC, all apps are closed

  • After reboot/restart, you have to re-open any app you'd like to use

New behavior:

  • When shutting down your PC, any open apps are "bookmarked" (for lack of a better word)
  • After reboot/restart, these apps will re-open automatically

If you want to start with no apps open (other than those set to auto-start via Task Manager/Start), you'll need to ensure all apps are closed before shutting down or restarting the PC.

 

I don't know about you, but I'm too lazy and am not going to close all my apps, one aften another, before I shutdown my PC. This is 2019, things should just work.

 

There are multple ways of solving this, but the most robust one is to create a shortcut in your startup menu to manually shutdown/restart your PC while forgoing on this annoying "feature". Here's a guide on how to do this, follow the method in Option 2(a) and then you can place your shortcuts in your startup folder (e.g. %AppData%\Microsoft\Windows\Start Menu\Programs).

6 Replies

Re: Spotify keeps opening on startup [Windows 10]

Alchemancy
Music Fan
It very much was a Spotify issue, but it has since been resolved back when
I first posted this. Roundabout solutions like the one you provided are
exactly what I was trying to avoid.

Re: Spotify keeps opening on startup [Windows 10]

havardlille
Newbie

Can not confirm that it's been fixed. Keeps happening here. It's disabled in both the program and in task manager.

 

Windows 10 build 17763.

Spotify 1.1.0.237.g378f6f25 Windows Store version.

Re: Spotify keeps opening on startup [Windows 10]

niuxen
Newbie

Same, happens on all my three Windows devices despite the NO flag... 

Re: Re: Spotify keeps opening on startup [Windows 10] - Status changed to: Need more info

Loxer
Rock Star 17
Rock Star 17

Hey all!

 

Could you try this Microsoft article to disable startup apps. 

Try to do a quick reinstallation and make sure to set off Spotify's startup behaviour in it's Advanced Settings and let me know the following if it did not help.

 

  • Your device
  • Your Windows version (find it using the Run window with the command winver)
  • Spotify version

It'll be investigated and you'll be able to get up-to-date here. Looking forward to your replies!

 

Have a nice day.

LoxerRock Star 17
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

Re: Re: Spotify keeps opening on startup [Windows 10] - Status changed to: Need more info

Katerina
Moderator
Moderator

Hey there folks,

 

Thanks for all your reports regarding the desktop app launching on Windows on startup.

 

If this issue occurs for you, we'd recommend following the steps @Loxer has mentioned here, making sure that you've selected to not launch Spotify at startup. You can do that from the app's Settings Show advanced settings > Startup and Window Behaviour.

 

You can also try a quick reinstall of the app and installing any pending software and driver updates on your device.

 

If none of these do the trick, make sure to add your +VOTE to stay updated. We'd like some additional information  (if you haven't left it already) so we can get this reported to the right folks:

  • Your device and its OS version
  • The exact version of the Spotify app
KaterinaModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
"Kindness is the language which the deaf can hear and the blind can see." - Mark Twain

Re: Spotify keeps opening on startup [Windows 10]

Peter
Moderator
Moderator

Hey folks,

 

We haven't heard from you in a while! As a result, we're going to move this thread back to the help boards.

 

If you're still experiencing this issue, make sure to open a new thread and we'll get back to you there.

 

Thanks!

PeterModerator
 
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
SUGGESTED POSTS