Help Wizard

Step 1

NEXT STEP

FAQs

Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...

VIEW ALL

Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...

VIEW ALL

Spotify Connect Being Greedy With Two Computers

Spotify Connect Being Greedy With Two Computers

So this is a small annoyance, but I have two computers that I regularly listen to music to using Spotify on (home and work). Both have the full client installed. Spotify connect is nice because it keeps both synced to what I was listening to so when I get home I can keep listening to what I was listening to at work. 

 

However, the computers both try to take precedence over the other when I just hit the play button. What used to happen would be if I hit play on my computer at home, even if I had been at work before, Spotify would start playing music from my computer at home. This makes sense because it's a computer, not a device. If I hit play I would like the computer that I'm on to start playing. Now, however, Spotify refuses to allow that happen and makes me go in and change what device is playing through the Connect screen. 

 

Obviously this is very annoying. Even if I click directly on a track in a playlist it will still start playing on the other machine, until I go in and change it. It feels as though if I'm on a computer Spotify should assume unless I specify otherwise that I want to listen to music on the computer itself. 

 

Is there any way to make this happen again or am I stuck making a feature request?

Reply
1 Reply

Hello @jckwik,

 

The reason Spotify does this is if you are listening to a device, but are using another device as the remote for Spotify. Such as you are on your computer and listening to music, but have an application that takes full screen and won't let you exit, then you can go to your phone and change songs and still be listening to the music through the computer.


There is no solution to turn off only half of the Spotify connect. Hope this helps.

Suggested posts