Announcements

Spotify Connect doesn't work with Sonos S1

Solved!

Spotify Connect doesn't work with Sonos S1

Plan

Premium

 

Country

Denmark

 

Devices

Samsung S21, Huawei P20 Pro

Samsung Galaxy Tab 10

Windows 10 Pro Desktop

Windows 10 Pro laptops

 

Operating Systems

Android 11

Windows 10 Pro

 

My Question or Issue

For some reason, I'm completely unable to connect to my Sonos S1 devices through the Spotify app. This problem exists on all devices and operating systems I've tried. Desktop, Laptop, Mobile phones, tablets.

I'm simply unable to select my Sonos devices through the app.

 

It has previously worked. Then it worked from time to time, and now it outright doesn't work.
It worked just fine when I was using Tidal earlier this year.

 

The Sonos devices are on my network. One via LAN cable, two via WiFi.
All of my devices are on the same network. Some via LAN-cables, some via WiFi.

 

My Spotify app(s) are up-to-date.
All devices’ softwares are up-to-date.
All Sonos devices are up-to-date.

 

I have not seen anywhere to enable "Control Sonos from Spotify"

 

An image tells more than a thousand words, so here's a bunch of photos that should be able to show my problem.

I wasn't able to upload images here, so I uploaded to imgur instead: https://imgur.com/a/LMkJm5k

 

I followed this guide from Sonos: https://support.sonos.com/s/article/1153?language=en_US

 

I have checked out and followed the following community posts:

Reply

Accepted Solutions
Marked as solution

Hi @Jeremy

Restaring the router didn't work.
Changing the network is quite a task, so I didn't try that out.

However, after months of troubleshooting and fiddleing with a lot of settings, I think I finally found the culprit...
I'm running a Unifi network, and after replacing mu USG with a UDM-PRO, I still had the problem.
But, I tried disabling Proxy ARP in Unifi, and that seems to be the culprit. After disabling Proxy ARP, I've been running for a month without any major problems (in regards to Spotify Connect). I just tried enabling Proxy ARP again, and immediately I got the problems back, and they disappeared when I disabled Proxy ARP.

I don't know the precise technical reason, but for some reason Sonos S1 devices are NOT happy with Proxy ARP, when all units are running on my own 2.4Ghz WiFi, and not on SonosNET. If they were running on their own SonosNET mesh network that might also have resolved the problem, I haven't tried

View solution in original post

7 Replies

Hey @KasperPlougmann,

 

Thanks for reaching out about this in the Community!

 

Since this started happening just recently and is affecting all of your Sonos devices, the issue might be firmware or account related.

 

You can try linking another Spotify account to your Sonos and check whether the speakers appear in the Connect menu there. You can ask a friend/ family member to log in with theirs or create a free account for test purposes.

 

You should also make sure that there are no firmware updates available for your speakers.

 

Keep us posted on how you get on with this.

AlexModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Hi @Alex as stated earlier all of my software and firmware (yes, all, I've checked every single device on the network) is updated to the latest version

 

I've linked my wife's spotify account to the sonos devices (though the S1 app). No change here, she experiences the same on all of her devices (and mine)

Hey @KasperPlougmann,

 

Thanks for keeping in touch.

 

Next thing you can try is removing Sonos from your Apps page here and doing the same with Spotify in the Sonos app, then add them again. The setting you need to enable in the Sonos app is Control from Other Devices.

 

We'd also like to know if the Sonos speaker appears in the Connect list in Spotify after you start the playback from the Sonos app.

 

We'll keep an eye out for your reply.

CarlosEModerator
 
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 

I removed Sonos from Spotify and Spotify from Sonos.
I then added them again. Went into the Sonos S1 app, added spotify, and by doing this, they were added in both Spotify and Sonos.

 

I then made sure that "Control from other apps" was enabled (see screenshot, it's in Danish).

 

I'm still not able to control my Sonos devices from any of my other devices, through the Spotify app. Not on mobile nor on Windows machines.

 

And no, it doesn't appear even when I start the playback in the S1 app.

Screenshot_20211214-223604_Sonos S1.jpg

Hi @KasperPlougmann,

 

Thank you for your reply in this thread.

 

Can you try a different network to see if the issue persists?

We also suggest that you restart your router.

 

Let us know how it goes.

 

Take care!

JeremyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂
Marked as solution

Hi @Jeremy

Restaring the router didn't work.
Changing the network is quite a task, so I didn't try that out.

However, after months of troubleshooting and fiddleing with a lot of settings, I think I finally found the culprit...
I'm running a Unifi network, and after replacing mu USG with a UDM-PRO, I still had the problem.
But, I tried disabling Proxy ARP in Unifi, and that seems to be the culprit. After disabling Proxy ARP, I've been running for a month without any major problems (in regards to Spotify Connect). I just tried enabling Proxy ARP again, and immediately I got the problems back, and they disappeared when I disabled Proxy ARP.

I don't know the precise technical reason, but for some reason Sonos S1 devices are NOT happy with Proxy ARP, when all units are running on my own 2.4Ghz WiFi, and not on SonosNET. If they were running on their own SonosNET mesh network that might also have resolved the problem, I haven't tried

Hi @KasperPlougmann,


Thanks for sharing what worked for you, as it may be helpful for other users too!

 

If you need a hand with anything else, the Community is here for you.

EniModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“Music acts like a magic key, to which the most tightly closed heart opens.”– Maria von Trapp

Suggested posts