Spotify Webplayer generates playlist in queue

Reply

Spotify Webplayer generates playlist in queue

HolyPastrami
Newbie

Plan

Free

Country

Germany

Device

Office PC

Operating System

Windows 10

 

My Question or Issue

Pretty much the title. I'm using the web player to play music, but even when i play single songs, Spotify generates an entire playlist in the queue. If i try to remove one of the songs, Spotify just adds it back in in the same place. You can appearantly turn this off in the Desktop version, but i cannot install that on this PC, as it's about as locked down as you'd expect from an office PC.

13 Replies

magichoo
Newbie

Same problem here for web player.

bonifacy
Regular

I have the same problem for web player.

I also have a spotify app for android and when I delete songs from the queue, they still remain there. Also I have 'Music non-stop' turned off in Spotify Android app. There is no such setting for Web player though.

Alex
Moderator
Moderator

Hey @HolyPastrami,

 

Thanks for reaching out about this in the Community!

 

On the Webplayer you can't adjust settings such as Autoplay (which you're describing).

 

You can try loggin in with your account on the Dektop appon on your home PC or the PC of friend > go to Settings > switch off Autoplay. This should be reflected on the webplayer even on your work PC. After that songs should not be automatically played when a playlist finishes.

 

Hope this helps. Don't hesitate to reach out agian if you have questions.

AlexModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

bonifacy
Regular

hi @Alex
how can I disable Autoplay in Spotify App for Android?
As I described I have 'Music non-stop' turned off in Spotify Android app.

JalapenoMunich
Roadie

https://community.spotify.com/t5/Other-Podcasts-Partners-etc/Connect-Autoplay-DISABLED-but-still-ACT...

 

It's a horrendous bug (if you ask the users) or a new feature (if you ask Spotify). It's been going on for three weeks and Spotify doesn't care that hundreds of people are complaining.

 

I've just cancelled my family subscription because of this. I'd avise you to do the same. Spotify isn't interested in changing this.

apvanzanten
Regular

I have the same issue on web player, my android app settings have no effect on the web players behavior. It keeps adding the tracks to the end of the album, regardless of whether the android app setting has autoplay on or off.

bonifacy
Regular

Ok, it seems to me that Spotify is not willing to do anything with that issue.

I tried to turn off Autoplay on Windows Desktop version - it still continues to play music after album is over.

Why even have an Autoplay option in settings, if it doesn't affect anything?

Do you want to force me to use Android app to listen to music to collect more personified data from me?

Do you want to feed me with your corporate music taste picked by your algorithm?

Well, I will not comply, F*** you Spotify and farewell.

Vill3m
Newbie

Same problem here since today. I don't want random songs to start playing immediately after listening to a specific song or album. It completely ruins the mood. I've been only listening to Spotify web version because the desktop app is slow af. I also checked that autoplay was off on both desktop and Android app even though I shouldn't have to check because I don't even use them.

CNT1
Regular
@Alex, your "solution" does not work at all.

Va_Sa
Regular

I have the same problem when I connect Spotify to an external device, using Spotify Connect (in my case a Denon mini hifi): it adds a playlist to the queue and I can't delete them. I hate it. I haven't got this problem when I listen the album with the app on my cellphone.

Va_Sa
Regular

When I connect Spotify to an external device, using Spotify Connect (in my case a Denon mini hifi) it adds songs to the queue and I can't delete them. I haven't got this problem when ai listen the album with the app on my cellphone. The autoplay option is set to off.

Screenshot_20211121-145626.png
Screenshot_20211121-145709.png

Mihail
Spotify Legend

Hey everyone,

 

Thanks for reaching out and sharing your feedback.

 

Having Autoplay turned on by default when using Connect is part of the recent changes that were made with this feature's redesign. It seems however that other users also requested this to be changed and posted this idea.  We recommend that you +VOTE it to show your support. We'll share any updates on the matter there, as soon as there are any, so it's worthwhile that you also subscribe.

 

Hope this info is useful. Take care!

Mihail Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

JalapenoMunich
Roadie

Nope, not useful, sorry. Nothing Spotify has done in the weeks since this bug has cropped up has been useful. You're simply ignoring hundreds of complaints from paying customers. You're SHOUTING "We don't care about you!". SHOUTING it. On repeat.

SUGGESTED POSTS